ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vitaly Brodetskyi (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-10431) Don't do anything when ambari-server setup executed ONLY with -s
Date Fri, 10 Apr 2015 11:17:13 GMT
Vitaly Brodetskyi created AMBARI-10431:
------------------------------------------

             Summary: Don't do anything when ambari-server setup executed ONLY with -s
                 Key: AMBARI-10431
                 URL: https://issues.apache.org/jira/browse/AMBARI-10431
             Project: Ambari
          Issue Type: Bug
          Components: ambari-server
    Affects Versions: 2.1.0
            Reporter: Vitaly Brodetskyi
            Assignee: Vitaly Brodetskyi
             Fix For: 2.1.0


I have a question about 'ambari-server setup' command option '-s' - silent setup.
When I do execute this first time it works as expected, but when I try to execute later something
like:
'ambari-server setup --database=mysql --databasehost=c6404 --databaseport=3306 --databasename=ambari
--databaseusername=ambari --databasepassword=bigdata --postgresschema=ambari -s'
It will say: 'Nothing was done. Please, use ambari-server setup command without [ -s ] key,
to change configuration'.
Is this expected behavior? If it is, then we will have problems with ambari DB setup in our
tests.
Because using command line arguments is much more easier and stable way to set DB properties,
then navigating through menu setup, because it behaves differently depending on OS type and
settings. This requires complex code to use text wizard in test code.
Maybe there can be some option '-f' for example to tell ambari-server setup that it should
execute in silent mode even if it was already set up.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message