ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vitaly Brodetskyi (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-10402) Ambari does not setup YARN NMs correctly with LinuxContainerExecutor in insecure mode
Date Wed, 08 Apr 2015 15:09:13 GMT
Vitaly Brodetskyi created AMBARI-10402:
------------------------------------------

             Summary: Ambari does not setup YARN NMs correctly with LinuxContainerExecutor
in insecure mode
                 Key: AMBARI-10402
                 URL: https://issues.apache.org/jira/browse/AMBARI-10402
             Project: Ambari
          Issue Type: Bug
          Components: ambari-server
    Affects Versions: 2.0.0
            Reporter: Vitaly Brodetskyi
            Assignee: Vitaly Brodetskyi
            Priority: Critical
             Fix For: 2.1.0


I tried setting up an insecure cluster with the following config changes (changes made via
Ambari) :

{code:xml}
    <property>
      <name>yarn.nodemanager.container-executor.class</name>
      <value>org.apache.hadoop.yarn.server.nodemanager.LinuxContainerExecutor</value>
    </property>
    <property>
      <name>yarn.nodemanager.linux-container-executor.resources-handler.class</name>
<value>org.apache.hadoop.yarn.server.nodemanager.util.CgroupsLCEResourcesHandler</value>
    </property>
    <property>
      <name>yarn.nodemanager.linux-container-executor.cgroups.mount</name>
      <value>true</value>
    </property>
    <property>
      <name>yarn.nodemanager.linux-container-executor.cgroups.mount-path</name>
      <value>/cgroups_test</value>
    </property>
{code}

The NMs don't come up with these changes.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message