ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tanping Wang <tanpi...@gmail.com>
Subject ambari-log4j-2.0.0.0-1 rpm Does Not Get Compiled Under 2.0 Source Code Tar Ball Automatically
Date Wed, 15 Apr 2015 18:34:12 GMT
Hello,
I found the package of ambari-log4j rpm does not get compiled using the
ambari 2.0 source code tar ball.  This package can be generated by
following the existing JIRA:

https://issues.apache.org/jira/browse/AMBARI-7604

This package is needed to generated and then yum installed on each ambari
agent node if some one wants to build and install from the source.

It might be a good idea to add the following manual steps to the ambari 2.0
wiki:

cd contrib/ambari-log4j
mvn package rpm:rpm -DskipTests
sudo yum install -y
target/rpm/ambari-log4j/RPMS/noarch/ambari-log4j-1.2.1-SNAPSHOT20141002001512.noarch.rpm

copy ambari-log4j*rpm to each ambari node and do
yum install ambari-log4j*rpm

Regards,
Tanping

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message