ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitro Lisnichenko" <dlysniche...@hortonworks.com>
Subject Review Request 33321: RU: Oozie upgrade fails when using oracle DB
Date Fri, 17 Apr 2015 19:17:37 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/33321/
-----------------------------------------------------------

Review request for Ambari and Dmytro Sen.


Bugs: AMBARI-10575
    https://issues.apache.org/jira/browse/AMBARI-10575


Repository: ambari


Description
-------

Rolling upgrade from 2.2 to 2.2.4.2 and facing following issue. I had no issue while running
the initial install.
Backend is Oracle database. I do have ojdbc6.jar under /usr/share/java and as per doc, I did
change permissions to 644

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 214, in execute
    method(env)
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 365, in restart
    self.pre_rolling_restart(env)
  File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server.py",
line 166, in pre_rolling_restart
    oozie_server_upgrade.upgrade_oozie()
  File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server_upgrade.py",
line 177, in upgrade_oozie
    Execute(command, user=params.oozie_user)
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 148, in __init__
    self.env.run()
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 152,
in run
    self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 118,
in run_action
    provider_action()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line
274, in action_run
    raise ex
Fail: Execution of '/usr/hdp/current/oozie-server/bin/ooziedb.sh upgrade -run' returned 1.
  setting OOZIE_CONFIG=${OOZIE_CONFIG:-/etc/oozie/conf}
  setting CATALINA_BASE=${CATALINA_BASE:-/usr/hdp/current/oozie-server/oozie-server}


Diffs
-----

  ambari-server/src/main/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server_upgrade.py
a14934b 

Diff: https://reviews.apache.org/r/33321/diff/


Testing
-------

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] Ambari Views ...................................... SUCCESS [2.109s]
[INFO] Ambari Metrics Common ............................. SUCCESS [1.288s]
[INFO] Ambari Server ..................................... SUCCESS [46.726s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 50.945s
[INFO] Finished at: Fri Apr 17 22:09:28 EEST 2015
[INFO] Final Memory: 49M/442M
[INFO] ------------------------------------------------------------------------


Thanks,

Dmitro Lisnichenko


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message