ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Fernandez" <afernan...@hortonworks.com>
Subject Re: Review Request 33059: Ambari Upgrade from 1.6.1 to 1.7.0 fails when analyzing global config groups with certain data
Date Mon, 13 Apr 2015 21:42:52 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/33059/
-----------------------------------------------------------

(Updated April 13, 2015, 9:42 p.m.)


Review request for Ambari, Jaimin Jetly and Sid Wagle.


Bugs: AMBARI-10356
    https://issues.apache.org/jira/browse/AMBARI-10356


Repository: ambari


Description
-------

Some values in the config_data column of table clusterconfig prevent UpgradeCatalog170 from
passing because the key is not a type that is recognized in the known config-types

E.g.,
{code}
{"zk_data_dir":"/hadoop/zookeeper"}
{code}


Diffs
-----

  ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog170.java db0506b


Diff: https://reviews.apache.org/r/33059/diff/


Testing (updated)
-------

I verified that the patch works, and was able to upgrade Ambari from 1.6.1 -> 1.7.0 ->
2.0.0
Unit tests passed on all relevant classes, but failed on known issues due to widgets.


Thanks,

Alejandro Fernandez


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message