ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Artem Baranchuk (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-10302) Oozie Client fails to install with 'java_version' is undefined
Date Tue, 31 Mar 2015 20:28:53 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-10302?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14389337#comment-14389337
] 

Artem Baranchuk commented on AMBARI-10302:
------------------------------------------

+1 for the patch

> Oozie Client fails to install with 'java_version' is undefined
> --------------------------------------------------------------
>
>                 Key: AMBARI-10302
>                 URL: https://issues.apache.org/jira/browse/AMBARI-10302
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>            Reporter: Dmitry Lysnichenko
>            Assignee: Dmitry Lysnichenko
>             Fix For: 2.1.0
>
>         Attachments: AMBARI-10302.patch
>
>
> While attempting to initially install a cluster containing Oozie, ran into this error:
> {code}
> stderr: 
> Traceback (most recent call last):
>   File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_client.py",
line 72, in <module>
>     OozieClient().execute()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 214, in execute
>     method(env)
>   File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_client.py",
line 35, in install
>     self.configure(env)
>   File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_client.py",
line 42, in configure
>     oozie(is_server=False)
>   File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie.py",
line 59, in oozie
>     content=InlineTemplate(params.oozie_env_sh_template)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 148,
in __init__
>     self.env.run()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
152, in run
>     self.run_action(resource, action)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
118, in run_action
>     provider_action()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py",
line 108, in action_create
>     content = self._get_content()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py",
line 150, in _get_content
>     return content()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/source.py", line 50,
in __call__
>     return self.get_content()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/source.py", line 132,
in get_content
>     rendered = self.template.render(self.context)
>   File "/usr/lib/python2.6/site-packages/ambari_jinja2/environment.py", line 891, in
render
>     return self.environment.handle_exception(exc_info, True)
>   File "<template>", line 71, in top-level template code
> ambari_jinja2.exceptions.UndefinedError: 'java_version' is undefined
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message