ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-10119) Rolling Upgrade "Upgrade" Action Actually Starts "Install Versions"
Date Wed, 18 Mar 2015 14:33:38 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-10119?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14367194#comment-14367194
] 

Hudson commented on AMBARI-10119:
---------------------------------

ABORTED: Integrated in Ambari-branch-2.0.0 #99 (See [https://builds.apache.org/job/Ambari-branch-2.0.0/99/])
AMBARI-10119 Rolling Upgrade "Upgrade" Action Actually Starts "Install Versions".  (ababiichuk)
(ababiichuk: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=4c2e1489ee6974bec42f72dbfb5cc6034425b0ea)
* ambari-web/test/views/main/admin/stack_upgrade/upgrade_version_box_view_test.js
* ambari-web/app/templates/main/admin/stack_upgrade/upgrade_version_box.hbs
* ambari-web/app/views/main/admin/stack_upgrade/upgrade_version_box_view.js


> Rolling Upgrade "Upgrade" Action Actually Starts "Install Versions"
> -------------------------------------------------------------------
>
>                 Key: AMBARI-10119
>                 URL: https://issues.apache.org/jira/browse/AMBARI-10119
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 2.0.0
>            Reporter: Andrii Babiichuk
>            Assignee: Andrii Babiichuk
>            Priority: Critical
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-10119.patch
>
>
> I created a clean cluster with all services and enabled NameNode HA in preparation for
an upgrade. I distributed my new HDP version to all 20 hosts, but some hosts failed because
of repository issues.
> I went to each failed host and manually retried the installation, which seems to work.
When I went to Manage Versions, it showed my new stack with only 18 out of 20 hosts upgraded.
I had to wait about 10 seconds for it to show me all 20 hosts had the correct stack version.

> At this time, the "Install" button changed to "Upgrade". I hit Upgrade, but the second
I hit it all 20 hosts went down to 0 for "Installed" and instead of an upgrade, Ambari tried
to re-install the stack on all hosts that already had it. 
> The installation went very quickly since all hosts already had the bits. 
> I noticed that, in general, the Stacks and Versions section was slow to update, sometimes
showing me information from several minutes ago. For example, I had 14 hosts installed, but
it only said 4 were. As I waited, it eventually caught up.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message