ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-10055) RU failed on RESTART Oozie Server because hadoop-lzo should only be copied if lzo compression is enabled
Date Fri, 13 Mar 2015 23:04:38 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-10055?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14361269#comment-14361269
] 

Hudson commented on AMBARI-10055:
---------------------------------

ABORTED: Integrated in Ambari-branch-2.0.0 #72 (See [https://builds.apache.org/job/Ambari-branch-2.0.0/72/])
AMBARI-10055. RU failed on RESTART Oozie Server because hadoop-lzo should only be copied if
lzo compression is enabled (alejandro) (afernandez: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=5e6ebdd4e22f1cb8c17f1419888dbd3cab83de04)
* ambari-server/src/main/resources/common-services/HDFS/2.1.0.2.0/package/scripts/hdfs.py
* ambari-server/src/test/python/stacks/2.2/configs/oozie-upgrade.json
* ambari-server/src/main/resources/common-services/HDFS/2.1.0.2.0/package/scripts/params.py
* ambari-server/src/test/python/stacks/2.2/configs/oozie-downgrade.json
* ambari-server/src/main/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server_upgrade.py
* ambari-server/src/main/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/params.py
* ambari-server/src/main/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie.py
* ambari-server/src/main/resources/custom_actions/scripts/install_packages.py
* ambari-server/src/test/python/stacks/2.0.6/OOZIE/test_oozie_server.py


> RU failed on RESTART Oozie Server because hadoop-lzo should only be copied if lzo compression
is enabled 
> ---------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-10055
>                 URL: https://issues.apache.org/jira/browse/AMBARI-10055
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.0.0
>            Reporter: Alejandro Fernandez
>            Assignee: Alejandro Fernandez
>              Labels: rolling_upgrade
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-10055.patch
>
>
> STR:
> Deploy a cluster with Oozie
> Confirm that lzo compression is not enabled ( http://docs.hortonworks.com/HDPDocuments/Ambari-1.6.0.0/bk_ambari_reference/content/ambari-ref-lzo-configure.html)
> Comment a Rolling Upgrade, which will fail in Oozie because it will not find the hadoop-lzo
jar.
> The jar should only be copied if lzo is enabled.
> {code}
> 2015-03-11 21:32:49,019 - u"Execute['hdp-select set oozie-server 2.2.2.0-2591']" {}
> 2015-03-11 21:32:49,064 - Restoring Oozie configuration directory after upgrade...
> 2015-03-11 21:32:49,065 - Extracting /tmp/oozie-upgrade-backup/oozie-conf-backup.tar
to /etc/oozie/conf
> 2015-03-11 21:32:49,179 - Error while executing command 'restart':
> Traceback (most recent call last):
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 214, in execute
>     method(env)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 365, in restart
>     self.pre_rolling_restart(env)
>   File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server.py",
line 165, in pre_rolling_restart
>     oozie_server_upgrade.prepare_libext_directory()
>   File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server_upgrade.py",
line 141, in prepare_libext_directory
>     hadoop_client_new_lib_dir, hadoop_lzo_pattern))
> Fail: There are no files at /usr/hdp/2.2.2.0-2591/hadoop/lib matching hadoop-lzo*.jar
> 2015-03-11 21:32:49,235 - Command: /usr/bin/hdp-select status oozie-server > /tmp/tmpVfVrGL
> Output: oozie-server - 2.2.2.0-2591
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message