ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alejandro Fernandez <afernan...@hortonworks.com>
Subject Re: MR2 smoke test and all jobs fail
Date Wed, 18 Mar 2015 17:46:09 GMT
When History Server starts, it will copy the mapreduce.tar.gz file to HDFS.
It determines where to copy the file to (e.g.,
hdfs:/prefix:8020/hdp/apps/<version>/mapreduce/mapreduce.tar.gz) by
finding the currently applied HDP version from the output of hdp-select.
What is the output of running?
hdp-select status

I suspect that two versions are installed, 2.2.0.0 GA bits and 2.2.3.0-2611

Thanks,
Alejandro

On 3/18/15, 10:20 AM, "Krisztian Horvath"
<krisztian.horvath@sequenceiq.com> wrote:

>As I see from the log during history server start: Could not verify HDP
>version by calling '/usr/bin/hdp-select versions > /tmp/tmpJsFu4o'.
>Return Code: 0, Output: 2.2.3.0-2611. There is no MR2 client in that
>hostgroup. Do you think I should add to that hostgroup as well?
>
>
>
>On March 18, 2015 at 5:48:15 PM, John Speidel (jspeidel@hortonworks.com)
>wrote:
>
>I think that this could occur if the MR2 client isn't installed on all
>hosts. 
>
>-John 
>________________________________________
>From: Krisztian Horvath <krisztian.horvath@sequenceiq.com>
>Sent: Wednesday, March 18, 2015 12:19 PM
>To: dev@ambari.apache.org
>Subject: MR2 smoke test and all jobs fail
>
>Hi, 
>
>Currently with Ambari 1.7 and HDP 2.2.3.0-2611 the MR2 smoke test fails
>with the following error: java.io.FileNotFoundException: File does not
>exist: 
>hdfs:/<consulnode>:8020/hdp/apps/2.2.3.0-2611/mapreduce/mapreduce.tar.gz
>. Few days ago with version 2.2.0.0-2041 it worked fine. Btw now every
>job fails with the same error. Does any1 know about this issue?
>
>Br, 
>Krisz 
>
>


Mime
View raw message