ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley" <jhur...@hortonworks.com>
Subject Re: Review Request 32054: RU failed on RESTART Oozie Server because hadoop-lzo should only be copied if lzo compression is enabled
Date Fri, 13 Mar 2015 19:59:27 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32054/#review76411
-----------------------------------------------------------

Ship it!


Ship It!


ambari-server/src/main/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server_upgrade.py
<https://reviews.apache.org/r/32054/#comment123958>

    Nice!


- Jonathan Hurley


On March 13, 2015, 2:45 p.m., Alejandro Fernandez wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/32054/
> -----------------------------------------------------------
> 
> (Updated March 13, 2015, 2:45 p.m.)
> 
> 
> Review request for Ambari, Jonathan Hurley and Sid Wagle.
> 
> 
> Bugs: AMBARI-10055
>     https://issues.apache.org/jira/browse/AMBARI-10055
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> STR:
> Deploy a cluster with Oozie
> Confirm that lzo compression is not enabled ( http://docs.hortonworks.com/HDPDocuments/Ambari-1.6.0.0/bk_ambari_reference/content/ambari-ref-lzo-configure.html)
> Comment a Rolling Upgrade, which will fail in Oozie because it will not find the hadoop-lzo
jar.
> 
> The jar should only be copied if lzo is enabled.
> 
> ```
> 2015-03-11 21:32:49,019 - u"Execute['hdp-select set oozie-server 2.2.2.0-2591']" {}
> 2015-03-11 21:32:49,064 - Restoring Oozie configuration directory after upgrade...
> 2015-03-11 21:32:49,065 - Extracting /tmp/oozie-upgrade-backup/oozie-conf-backup.tar
to /etc/oozie/conf
> 2015-03-11 21:32:49,179 - Error while executing command 'restart':
> Traceback (most recent call last):
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 214, in execute
>     method(env)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 365, in restart
>     self.pre_rolling_restart(env)
>   File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server.py",
line 165, in pre_rolling_restart
>     oozie_server_upgrade.prepare_libext_directory()
>   File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server_upgrade.py",
line 141, in prepare_libext_directory
>     hadoop_client_new_lib_dir, hadoop_lzo_pattern))
> Fail: There are no files at /usr/hdp/2.2.2.0-2591/hadoop/lib matching hadoop-lzo*.jar
> 2015-03-11 21:32:49,235 - Command: /usr/bin/hdp-select status oozie-server > /tmp/tmpVfVrGL
> Output: oozie-server - 2.2.2.0-2591
> ```
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/resources/common-services/HDFS/2.1.0.2.0/package/scripts/hdfs.py
795b315 
>   ambari-server/src/main/resources/common-services/HDFS/2.1.0.2.0/package/scripts/params.py
ed214b8 
>   ambari-server/src/main/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie.py
c0f6c3a 
>   ambari-server/src/main/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server_upgrade.py
c5b420f 
>   ambari-server/src/main/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/params.py
c4a7596 
>   ambari-server/src/main/resources/custom_actions/scripts/install_packages.py eb93e18

>   ambari-server/src/test/python/stacks/2.0.6/OOZIE/test_oozie_server.py dc4bc7f 
>   ambari-server/src/test/python/stacks/2.2/configs/oozie-downgrade.json 69125ce 
>   ambari-server/src/test/python/stacks/2.2/configs/oozie-upgrade.json 20bf589 
> 
> Diff: https://reviews.apache.org/r/32054/diff/
> 
> 
> Testing
> -------
> 
> I verified the patch works.
> 
> * Enabled lzo by following http://docs.hortonworks.com/HDPDocuments/Ambari-1.6.0.0/bk_ambari_reference/content/ambari-ref-lzo-configure.html
> * Ensured that was still able to restart Oozie server
> * Took a snapshot of the VM
>     * Installed new version HDP 2.2.2.0-2603, which correctly downloaded the lzo jar
to /usr/hdp/2.2.2.0-2603/hadoop/lib/hadoop-lzo-0.6.0.2.2.2.0-2603.jar. Was then able to perform
a successful RU.
>     * Reverted the LZO configs, and installed new version HDP 2.2.2.0-2603, which did
not download the lzo jar. Was then able to perform a successful RU.
> 
> Basically, the Oozie Server RU will only require the hadoop lzo to exist if lzo is enabled.
> 
> Python unit tests passed,
> ----------------------------------------------------------------------
> Total run:613
> Total errors:0
> Total failures:0
> OK
> 
> 
> Thanks,
> 
> Alejandro Fernandez
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message