ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Lysnichenko (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-9773) RU - Unnecessary "Upgrade Requirements Not Met" alert appears before rolling upgrade
Date Tue, 24 Feb 2015 17:43:04 GMT
Dmitry Lysnichenko created AMBARI-9773:
------------------------------------------

             Summary: RU - Unnecessary "Upgrade Requirements Not Met" alert appears before
rolling upgrade
                 Key: AMBARI-9773
                 URL: https://issues.apache.org/jira/browse/AMBARI-9773
             Project: Ambari
          Issue Type: Bug
          Components: ambari-server
    Affects Versions: 2.0.0
            Reporter: Dmitry Lysnichenko
            Assignee: Dmitry Lysnichenko
             Fix For: 2.0.0


Steps to reproduce:
- Install all services 2.2.2.0-2451
- Enable HA.
- Create repo 2.2.2.0-2454
- Perform Upgrade.
Note a dialog show and say "You must meet the following requirements before you can proceed
with rolling upgrade." 

{code}
Reason: MapReduce should reference hadoop libraries from the distributed cache. Make sure
that mapreduce.application.framework.path and mapreduce.application.classpath properties are
present in mapred.site.xml and point to hdfs:/... urls
Failed on: MAP_REDUCE
 Oozie should reference hadoop libraries from the distributed cache
Reason: MapReduce on cluster c1_ubuntu_434 should reference hadoop libraries from the distributed
cache. Make sure that mapreduce.application.framework.path and mapreduce.application.classpath
properties are present in mapred.site.xmland point to hdfs:/... urls
Failed on: OOZIE
 TEZ should reference hadoop libraries from the distributed cache
Reason: tez-site property tez.lib.uris should point to hdfs:/... url with .tar.gz archive
of TEZ binaries
Failed on: TEZ
{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message