ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-9694) Views: Login redirection fails in Ambari when trying to access view
Date Thu, 19 Feb 2015 14:40:11 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-9694?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14327517#comment-14327517
] 

Hudson commented on AMBARI-9694:
--------------------------------

SUCCESS: Integrated in Ambari-view #7 (See [https://builds.apache.org/job/Ambari-view/7/])
AMBARI-9694 - Views: Login redirection fails in Ambari when trying to access view (tbeerbower)
(tbeerbower: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=4e7134c86d12451b8ae86cb8594d7b2bc29a0643)
* ambari-server/src/test/java/org/apache/ambari/server/security/authorization/AmbariAuthorizationFilterTest.java
* ambari-server/src/main/java/org/apache/ambari/server/security/authorization/AmbariAuthorizationFilter.java


> Views: Login redirection fails in Ambari when trying to access view
> -------------------------------------------------------------------
>
>                 Key: AMBARI-9694
>                 URL: https://issues.apache.org/jira/browse/AMBARI-9694
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Tom Beerbower
>            Assignee: Tom Beerbower
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-9694.patch
>
>
> Access a view (i.e. "http://c6501.ambari.apache.org:8080/views/TEZ/0.5.2.2.2.2.0-869/tez/#/tez-app/application_1423719241211_0050")
from a browser where I have already logged in to Ambari, the link works fine. 
> When I access it from another browser, I get a 403 with no redirect to the login page.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message