ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrii Tkach (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-9527) RU: FE must issue an ABORTED to an upgrade before starting a downgrade
Date Fri, 06 Feb 2015 20:21:34 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-9527?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrii Tkach updated AMBARI-9527:
---------------------------------
    Attachment: AMBARI-9527.patch

> RU: FE must issue an ABORTED to an upgrade before starting a downgrade
> ----------------------------------------------------------------------
>
>                 Key: AMBARI-9527
>                 URL: https://issues.apache.org/jira/browse/AMBARI-9527
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-web
>    Affects Versions: 2.0.0
>            Reporter: Andrii Tkach
>            Assignee: Andrii Tkach
>            Priority: Blocker
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-9527.patch
>
>
> The FE must issue an ABORTED call to a current upgrade before issuing the downgrade request.
> The UI must also wait for the abort to complete before starting an upgrade.
> I marked as blocker, but it's really "mutually blocked" with BUG-30750. Every time I
try to fully test BUG-30750 on Downgrade, the UI is telling me the upgrade is completely finished
and the button goes away.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message