ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-8342) Requesting the config_groups collection resource with no registered configuration groups results in a 404 response
Date Mon, 02 Feb 2015 22:54:43 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-8342?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14302124#comment-14302124
] 

Hudson commented on AMBARI-8342:
--------------------------------

FAILURE: Integrated in Ambari-trunk-Commit-docker #841 (See [https://builds.apache.org/job/Ambari-trunk-Commit-docker/841/])
AMBARI-8342 - Requesting the config_groups collection resource with no registered configuration
groups results in a 404 response (tbeerbower) (tbeerbower: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=474cfcd3db4d686b8036e429976678bbe7dc5c92)
* ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ClusterControllerImplTest.java
* ambari-server/src/main/java/org/apache/ambari/server/api/query/QueryImpl.java
* ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ClusterControllerImpl.java
* ambari-server/src/test/java/org/apache/ambari/server/api/query/QueryImplTest.java


> Requesting the config_groups collection resource with no registered configuration groups
results in a 404 response
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-8342
>                 URL: https://issues.apache.org/jira/browse/AMBARI-8342
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 1.7.0
>            Reporter: John Speidel
>            Assignee: Tom Beerbower
>              Labels: api
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-8342.patch
>
>
> GET http://AMBARI_HOST:8080/api/v1/clusters/c1/config_groups
> {
>   "status" : 404,
>   "message" : "The requested resource doesn't exist: ConfigGroup not found, ConfigGroup/cluster_name=c1"
> }
> The cluster c1 exists and has no configuration groups.  The above response is incorrect.
 As per the api specification, it should return an empty collection.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message