ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yurii Shylov" <yurii.shy...@gmail.com>
Subject Re: Review Request 30568: Rolling Upgrade Bootstrap - Allow Ambari upgrade from 1.7.0 - 2.0.0 to populate new tables
Date Thu, 12 Feb 2015 17:27:16 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/30568/
-----------------------------------------------------------

(Updated Фев. 12, 2015, 5:27 п.п.)


Review request for Ambari, Alejandro Fernandez, Dmitro Lisnichenko, and Nate Cole.


Changes
-------

Rebased on latest trunk as the patch stopped applying.
Can we get this pushed?


Bugs: AMBARI-9054
    https://issues.apache.org/jira/browse/AMBARI-9054


Repository: ambari


Description
-------

During the upgrade process, populate the repo_version, cluster_version, and host_version tables.


Diffs (updated)
-----

  ambari-common/src/main/python/resource_management/libraries/script/script.py 683397a 
  ambari-server/src/main/java/org/apache/ambari/server/agent/ComponentStatus.java a71bbd1

  ambari-server/src/main/java/org/apache/ambari/server/agent/HeartBeatHandler.java b60af2f

  ambari-server/src/main/java/org/apache/ambari/server/agent/HeartbeatMonitor.java 4fe219c


Diff: https://reviews.apache.org/r/30568/diff/


Testing
-------

UPD: manual testing done again. I couldn't get through finalize but it was caused by another
issue. Database state and logs show that patch doesn't make changes to regulare RU workflow.

Manual testing done, UT passing


Thanks,

Yurii Shylov


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message