ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-9134) Unable to Upgrade Oozie Server Due to Missing JAR
Date Thu, 15 Jan 2015 05:52:34 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-9134?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14278294#comment-14278294
] 

Hudson commented on AMBARI-9134:
--------------------------------

SUCCESS: Integrated in Ambari-trunk-Commit #1495 (See [https://builds.apache.org/job/Ambari-trunk-Commit/1495/])
AMBARI-9134 - Unable to Upgrade Oozie Server Due to Missing JAR (jonathanhurley) (jhurley:
http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=5620318518f4899eab81a122ec6a952356adcb7b)
* ambari-server/src/main/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/params.py
* ambari-server/src/test/python/stacks/2.0.6/OOZIE/test_oozie_server.py
* ambari-server/src/main/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server_upgrade.py


> Unable to Upgrade Oozie Server Due to Missing JAR
> -------------------------------------------------
>
>                 Key: AMBARI-9134
>                 URL: https://issues.apache.org/jira/browse/AMBARI-9134
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-server
>    Affects Versions: 2.0.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Critical
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-9134.patch
>
>
> During an upgrade, Oozie fails to restart:
> {noformat}
> Traceback (most recent call last):
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 175, in execute
>     method(env)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 325, in restart
>     self.pre_rolling_restart(env)
>   File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server.py",
line 167, in pre_rolling_restart
>     oozie_server_upgrade.prepare_libext_directory()
>   File "/var/lib/ambari-agent/cache/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_server_upgrade.py",
line 136, in prepare_libext_directory
>     params.hadoop_lib_home, hadoop_lzo_pattern))
> Fail: There are no files at /usr/hdp/current/hadoop-client/lib matching hadoop-lzo*.jar
> {noformat}
> The problem is that the hadoop-lzo*.jar is being copied from hadoop-client where it doesn't
exist yet since hadoop-client has not yet been upgraded.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message