ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-9133) Views: min and max version
Date Mon, 19 Jan 2015 20:41:35 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-9133?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14282975#comment-14282975
] 

Hudson commented on AMBARI-9133:
--------------------------------

SUCCESS: Integrated in Ambari-trunk-Commit #1531 (See [https://builds.apache.org/job/Ambari-trunk-Commit/1531/])
AMBARI-9133 - Views: min and max version (tbeerbower) (tbeerbower: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=ddf020dd6102b1918a0d9e1c669f3e54765cd344)
* ambari-server/src/main/java/org/apache/ambari/server/view/ViewRegistry.java
* ambari-views/src/main/resources/view.xsd
* ambari-server/src/test/java/org/apache/ambari/server/view/ViewRegistryTest.java
* ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ViewPrivilegeResourceProviderTest.java
* ambari-server/src/test/java/org/apache/ambari/server/controller/internal/AmbariPrivilegeResourceProviderTest.java
* ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ViewVersionResourceProvider.java
* ambari-server/src/test/java/org/apache/ambari/server/view/configuration/ViewConfigTest.java
* ambari-server/src/main/java/org/apache/ambari/server/view/configuration/ViewConfig.java
* ambari-server/src/test/java/org/apache/ambari/server/orm/entities/ViewEntityTest.java
* ambari-server/src/main/java/org/apache/ambari/server/orm/entities/ViewEntity.java


> Views: min and max version
> --------------------------
>
>                 Key: AMBARI-9133
>                 URL: https://issues.apache.org/jira/browse/AMBARI-9133
>             Project: Ambari
>          Issue Type: Improvement
>            Reporter: Tom Beerbower
>            Assignee: Tom Beerbower
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-9133.patch
>
>
> Add support for including optional min, max or min+max Ambari version in view.xml. This
can include exact versions or variables. A few examples:
> <min-ambari-version>1.7.0</min-ambari-version>
> <min-ambari-version>1.7.*</min-ambari-version>
> <max-ambari-version>1.*</max-ambari-version>
> On deploy, ambari should validate the view meets the min/max specified and if not, not
deploy and produce an error in the log with the details (for example: "view requires minimum
ambari version 1.7") 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message