ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Lysnichenko (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-9120) Parallel package installation under SLES misbehaves
Date Mon, 19 Jan 2015 17:02:34 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-9120?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dmitry Lysnichenko updated AMBARI-9120:
---------------------------------------
    Attachment: AMBARI-9120.2.patch

> Parallel package installation under SLES misbehaves
> ---------------------------------------------------
>
>                 Key: AMBARI-9120
>                 URL: https://issues.apache.org/jira/browse/AMBARI-9120
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-server
>    Affects Versions: 2.0.0
>            Reporter: Dmitry Lysnichenko
>            Assignee: Dmitry Lysnichenko
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-9120.2.patch, AMBARI-9120.patch
>
>
> h2. The first issue:
> When installing second stack version in parallel, dependencies for the second stack version
are not installed 
> {code}
> 143:/tmp/rpms_suse11 # zypper search hadoop_2_2_*
> Loading repository data...                                                          
                            
> Reading installed packages...                                                       
                            
> S | Name                                        | Summary                           
                | Type      
> --+---------------------------------------------+----------------------------------------------------+-----------
>   | hadoop_2_2_0_0_2041                         | Hadoop is a software platform for processing
vas-> | srcpackage
> i | hadoop_2_2_0_0_2041                         | Hadoop is a software platform for processing
vas-> | package   
> i | hadoop_2_2_0_0_2041-client                  | Hadoop client side dependencies   
                | package   
> i | hadoop_2_2_0_0_2041-conf-pseudo             | Pseudo-distributed Hadoop configuration
           | package   
> i | hadoop_2_2_0_0_2041-doc                     | Hadoop Documentation              
                | package   
> i | hadoop_2_2_0_0_2041-hdfs                    | The Hadoop Distributed File System
                | package   
> i | hadoop_2_2_0_0_2041-hdfs-datanode           | Hadoop Data Node                  
                | package   
> i | hadoop_2_2_0_0_2041-hdfs-fuse               | Mountable HDFS                    
                | package   
> i | hadoop_2_2_0_0_2041-hdfs-journalnode        | Hadoop HDFS JournalNode           
                | package   
> i | hadoop_2_2_0_0_2041-hdfs-namenode           | The Hadoop namenode manages the block
locations -> | package   
> i | hadoop_2_2_0_0_2041-hdfs-secondarynamenode  | Hadoop Secondary namenode         
                | package   
> i | hadoop_2_2_0_0_2041-hdfs-zkfc               | Hadoop HDFS failover controller   
                | package   
> i | hadoop_2_2_0_0_2041-httpfs                  | HTTPFS for Hadoop                 
                | package   
> i | hadoop_2_2_0_0_2041-libhdfs                 | Hadoop Filesystem Library         
                | package   
> i | hadoop_2_2_0_0_2041-mapreduce               | The Hadoop MapReduce (MRv2)       
                | package   
> i | hadoop_2_2_0_0_2041-mapreduce-historyserver | MapReduce History Server          
                | package   
> i | hadoop_2_2_0_0_2041-source                  | Source code for Hadoop            
                | package   
> i | hadoop_2_2_0_0_2041-yarn                    | The Hadoop NextGen MapReduce (YARN)
               | package   
> i | hadoop_2_2_0_0_2041-yarn-nodemanager        | YARN Node Manager                 
                | package   
> i | hadoop_2_2_0_0_2041-yarn-proxyserver        | YARN Web Proxy                    
                | package   
> i | hadoop_2_2_0_0_2041-yarn-resourcemanager    | YARN Resource Manager             
                | package   
>   | hadoop_2_2_1_0_2171                         | Hadoop is a software platform for processing
vas-> | srcpackage
>   | hadoop_2_2_1_0_2171                         | Hadoop is a software platform for processing
vas-> | package   
>   | hadoop_2_2_1_0_2171-client                  | Hadoop client side dependencies   
                | package   
>   | hadoop_2_2_1_0_2171-conf-pseudo             | Pseudo-distributed Hadoop configuration
           | package   
>   | hadoop_2_2_1_0_2171-doc                     | Hadoop Documentation              
                | package   
>   | hadoop_2_2_1_0_2171-hdfs                    | The Hadoop Distributed File System
                | package   
>   | hadoop_2_2_1_0_2171-hdfs-datanode           | Hadoop Data Node                  
                | package   
>   | hadoop_2_2_1_0_2171-hdfs-fuse               | Mountable HDFS                    
                | package   
>   | hadoop_2_2_1_0_2171-hdfs-journalnode        | Hadoop HDFS JournalNode    
>   | hadoop_2_2_1_0_2171-hdfs-namenode           | The Hadoop namenode manages
>   | hadoop_2_2_1_0_2171-hdfs-secondarynamenode  | Hadoop Secondary namenode  
>   | hadoop_2_2_1_0_2171-hdfs-zkfc               | Hadoop HDFS failover contro
>   | hadoop_2_2_1_0_2171-httpfs                  | HTTPFS for Hadoop          
>   | hadoop_2_2_1_0_2171-libhdfs                 | Hadoop Filesystem Library  
>   | hadoop_2_2_1_0_2171-mapreduce               | The Hadoop MapReduce (MRv2)
>   | hadoop_2_2_1_0_2171-mapreduce-historyserver | MapReduce History Server   
>   | hadoop_2_2_1_0_2171-source                  | Source code for Hadoop     
>   | hadoop_2_2_1_0_2171-yarn                    | The Hadoop NextGen MapReduc
>   | hadoop_2_2_1_0_2171-yarn-nodemanager        | YARN Node Manager          
>   | hadoop_2_2_1_0_2171-yarn-proxyserver        | YARN Web Proxy             
>   | hadoop_2_2_1_0_2171-yarn-resourcemanager    | YARN Resource Manager      
>   | hadoop_2_2_1_0_2172                         | Hadoop is a software platfo
>   | hadoop_2_2_1_0_2172                         | Hadoop is a software platfo
>   | hadoop_2_2_1_0_2172-client                  | Hadoop client side dependen
>   | hadoop_2_2_1_0_2172-conf-pseudo             | Pseudo-distributed Hadoop c
>   | hadoop_2_2_1_0_2172-doc                     | Hadoop Documentation       
>   | hadoop_2_2_1_0_2172-hdfs                    | The Hadoop Distributed File
>   | hadoop_2_2_1_0_2172-hdfs-datanode           | Hadoop Data Node           
>   | hadoop_2_2_1_0_2172-hdfs-fuse               | Mountable HDFS             
>   | hadoop_2_2_1_0_2172-hdfs-journalnode        | Hadoop HDFS JournalNode    
>   | hadoop_2_2_1_0_2172-hdfs-namenode           | The Hadoop namenode manages
>   | hadoop_2_2_1_0_2172-hdfs-secondarynamenode  | Hadoop Secondary namenode  
>   | hadoop_2_2_1_0_2172-hdfs-zkfc               | Hadoop HDFS failover contro
>   | hadoop_2_2_1_0_2172-httpfs                  | HTTPFS for Hadoop          
>   | hadoop_2_2_1_0_2172-libhdfs                 | Hadoop Filesystem Library  
>   | hadoop_2_2_1_0_2172-mapreduce               | The Hadoop MapReduce (MRv2)
>   | hadoop_2_2_1_0_2172-mapreduce-historyserver | MapReduce History Server   
>   | hadoop_2_2_1_0_2172-source                  | Source code for Hadoop     
>   | hadoop_2_2_1_0_2172-yarn                    | The Hadoop NextGen MapReduc
>   | hadoop_2_2_1_0_2172-yarn-nodemanager        | YARN Node Manager          
>   | hadoop_2_2_1_0_2172-yarn-proxyserver        | YARN Web Proxy             
>   | hadoop_2_2_1_0_2172-yarn-resourcemanager    | YARN Resource Manager      
>   | hadoop_2_2_1_0_2175                         | Hadoop is a software platfo
> i | hadoop_2_2_1_0_2175                         | Hadoop is a software platfo
>   | hadoop_2_2_1_0_2175-client                  | Hadoop client side dependen
>   | hadoop_2_2_1_0_2175-conf-pseudo             | Pseudo-distributed Hadoop c
>   | hadoop_2_2_1_0_2175-doc                     | Hadoop Documentation       
>   | hadoop_2_2_1_0_2175-hdfs                    | The Hadoop Distributed File
>   | hadoop_2_2_1_0_2175-hdfs-datanode           | Hadoop Data Node           
>   | hadoop_2_2_1_0_2175-hdfs-fuse               | Mountable HDFS             
>   | hadoop_2_2_1_0_2175-hdfs-journalnode        | Hadoop HDFS JournalNode    
>   | hadoop_2_2_1_0_2175-hdfs-namenode           | The Hadoop namenode manages
>   | hadoop_2_2_1_0_2175-hdfs-secondarynamenode  | Hadoop Secondary namenode  
>   | hadoop_2_2_1_0_2175-hdfs-zkfc               | Hadoop HDFS failover contro
>   | hadoop_2_2_1_0_2175-httpfs                  | HTTPFS for Hadoop          
>   | hadoop_2_2_1_0_2175-libhdfs                 | Hadoop Filesystem Library  
>   | hadoop_2_2_1_0_2175-mapreduce               | The Hadoop MapReduce (MRv2)
>   | hadoop_2_2_1_0_2175-mapreduce-historyserver | MapReduce History Server   
>   | hadoop_2_2_1_0_2175-source                  | Source code for Hadoop     
>   | hadoop_2_2_1_0_2175-yarn                    | The Hadoop NextGen MapReduc
>   | hadoop_2_2_1_0_2175-yarn-nodemanager        | YARN Node Manager          
>   | hadoop_2_2_1_0_2175-yarn-proxyserver        | YARN Web Proxy             
>   | hadoop_2_2_1_0_2175-yarn-resourcemanager    | YARN Resource Manager
> {code}
> h2. The second issue:
> When trying to install older stack version in parallel with newer stack version, zypper
refuses to install packages even through it has been restricted to relevant repositories.
Looks like we have to append concrete repo versions before asterisk at globs like hadoop_2_2_*
> {code}
> 2015-01-05 13:03:08,685 - Repository['HDP-UTILS-2.2.1.0-2171'] {'append_to_file': False,
'base_url': 'http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/suse11sp3', 'action':
['create'], 'components': [u'HDP-UTILS-2.2.1.0-2171', 'main'], 'repo_template': 'repo_suse_rhel.j2',
'repo_file_name': 'HDP-2.2.1.0-2171', 'mirror_list': None}
> 2015-01-05 13:03:08,695 - File['/etc/zypp/repos.d/HDP-2.2.1.0-2171.repo'] {'content':
Template('repo_suse_rhel.j2')}
> 2015-01-05 13:03:08,696 - Writing File['/etc/zypp/repos.d/HDP-2.2.1.0-2171.repo'] because
it doesn't exist
> 2015-01-05 13:03:08,775 - Repository['HDP-2.2.1.0-2171'] {'append_to_file': True, 'base_url':
'http://s3.amazonaws.com/dev.hortonworks.com/HDP/suse11sp3/2.x/BUILDS/2.2.1.0-2171/', 'action':
['create'], 'components': [u'HDP-2.2.1.0-2171', 'main'], 'repo_template': 'repo_suse_rhel.j2',
'repo_file_name': 'HDP-2.2.1.0-2171', 'mirror_list': None}
> 2015-01-05 13:03:12,997 - Package['zookeeper_2_2_*'] {'use_repos': ['base', 'HDP-UTILS-2.2.1.0-2171',
'HDP-2.2.1.0-2171']}
> 2015-01-05 13:03:13,870 - Installing package zookeeper_2_2_* ('/usr/bin/zypper install
--auto-agree-with-licenses --no-confirm --repo HDP-UTILS-2.2.1.0-2171 --repo HDP-2.2.1.0-2171
--repo opensuse 'zookeeper_2_2_*'')
> Loading repository data...
> Reading installed packages...
> 'zookeeper_2_2_0_0_2041' providing 'zookeeper_2_2_*' is already installed.
> Package 'zookeeper_2_2_0_0_2041' is not available in your repositories. Cannot reinstall,
upgrade, or downgrade.
> Resolving package dependencies...
> Nothing to do.
> 2015-01-05 13:03:14,559 - Package['hadoop_2_2_*'] {'use_repos': ['base', 'HDP-UTILS-2.2.1.0-2171',
'HDP-2.2.1.0-2171']}
> 2015-01-05 13:03:15,345 - Installing package hadoop_2_2_* ('/usr/bin/zypper install --auto-agree-with-licenses
--no-confirm --repo HDP-UTILS-2.2.1.0-2171 --repo HDP-2.2.1.0-2171 --repo opensuse 'hadoop_2_2_*'')
> Loading repository data...
> Reading installed packages...
> 'hadoop_2_2_0_0_2041-hdfs' providing 'hadoop_2_2_*' is already installed.
> Package 'hadoop_2_2_0_0_2041-hdfs' is not available in your repositories. Cannot reinstall,
upgrade, or downgrade.
> Resolving package dependencies...
> Nothing to do.
> 2015-01-05 13:03:16,023 - Package['snappy'] {'use_repos': ['base', 'HDP-UTILS-2.2.1.0-2171',
'HDP-2.2.1.0-2171']}
> 2015-01-05 13:03:16,804 - Installing package snappy ('/usr/bin/zypper install --auto-agree-with-licenses
--no-confirm --repo HDP-UTILS-2.2.1.0-2171 --repo HDP-2.2.1.0-2171 --repo opensuse snappy')
> Loading repository data...
> Reading installed packages...
> 'snappy' is already installed.
> No update candidate for 'snappy-1.0.5-1.x86_64'. The highest available version is already
installed.
> Resolving package dependencies...
> Nothing to do.
> 2015-01-05 13:03:17,504 - Package['snappy-devel'] {'use_repos': ['base', 'HDP-UTILS-2.2.1.0-2171',
'HDP-2.2.1.0-2171']}
> 2015-01-05 13:03:18,291 - Installing package snappy-devel ('/usr/bin/zypper install --auto-agree-with-licenses
--no-confirm --repo HDP-UTILS-2.2.1.0-2171 --repo HDP-2.2.1.0-2171 --repo opensuse snappy-devel')
> Loading repository data...
> Reading installed packages...
> 'snappy-devel' is already installed.
> No update candidate for 'snappy-devel-1.0.5-1.x86_64'. The highest available version
is already installed.
> Resolving package dependencies...
> Nothing to do.
> 2015-01-05 13:03:19,259 - Package['lzo'] {'use_repos': ['base', 'HDP-UTILS-2.2.1.0-2171',
'HDP-2.2.1.0-2171']}
> 2015-01-05 13:03:20,061 - Installing package lzo ('/usr/bin/zypper install --auto-agree-with-licenses
--no-confirm --repo HDP-UTILS-2.2.1.0-2171 --repo HDP-2.2.1.0-2171 --repo opensuse lzo')
> Loading repository data...
> Reading installed packages...
> 'lzo' is already installed.
> No update candidate for 'lzo-2.06-1.x86_64'. The highest available version is already
installed.
> Resolving package dependencies...
> Nothing to do.
> 2015-01-05 13:03:20,745 - Package['hadooplzo_2_2_*'] {'use_repos': ['base', 'HDP-UTILS-2.2.1.0-2171',
'HDP-2.2.1.0-2171']}
> 2015-01-05 13:03:21,519 - Installing package hadooplzo_2_2_* ('/usr/bin/zypper install
--auto-agree-with-licenses --no-confirm --repo HDP-UTILS-2.2.1.0-2171 --repo HDP-2.2.1.0-2171
--repo opensuse 'hadooplzo_2_2_*'')
> Loading repository data...
> Reading installed packages...
> 'hadooplzo_2_2_1_0_2175' providing 'hadooplzo_2_2_*' is already installed.
> Package 'hadooplzo_2_2_1_0_2175' is not available in your repositories. Cannot reinstall,
upgrade, or downgrade.
> Resolving package dependencies...
> Nothing to do.
> 2015-01-05 13:03:22,199 - Package['hadoop_2_2_*-libhdfs'] {'use_repos': ['base', 'HDP-UTILS-2.2.1.0-2171',
'HDP-2.2.1.0-2171']}
> 2015-01-05 13:03:22,980 - Installing package hadoop_2_2_*-libhdfs ('/usr/bin/zypper install
--auto-agree-with-licenses --no-confirm --repo HDP-UTILS-2.2.1.0-2171 --repo HDP-2.2.1.0-2171
--repo opensuse 'hadoop_2_2_*-libhdfs'')
> Loading repository data...
> Reading installed packages...
> 'hadoop_2_2_0_0_2041-libhdfs' providing 'hadoop_2_2_*-libhdfs' is already installed.
> Package 'hadoop_2_2_0_0_2041-libhdfs' is not available in your repositories. Cannot reinstall,
upgrade, or downgrade.
> Resolving package dependencies...
> Nothing to do.
> 2015-01-05 13:03:23,666 - Package['ambari-log4j'] {'use_repos': ['base', 'HDP-UTILS-2.2.1.0-2171',
'HDP-2.2.1.0-2171']}
> 2015-01-05 13:03:24,427 - Installing package ambari-log4j ('/usr/bin/zypper install --auto-agree-with-licenses
--no-confirm --repo HDP-UTILS-2.2.1.0-2171 --repo HDP-2.2.1.0-2171 --repo opensuse ambari-log4j')
> Loading repository data...
> Reading installed packages...
> 'ambari-log4j' is already installed.
> Package 'ambari-log4j' is not available in your repositories. Cannot reinstall, upgrade,
or downgrade.
> Resolving package dependencies...
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message