ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oleg Nechiporenko (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-9046) templeton.hive.properties set incorrectly
Date Thu, 08 Jan 2015 16:11:34 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-9046?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Oleg Nechiporenko updated AMBARI-9046:
--------------------------------------
    Attachment: AMBARI-9046.patch

> templeton.hive.properties set incorrectly
> -----------------------------------------
>
>                 Key: AMBARI-9046
>                 URL: https://issues.apache.org/jira/browse/AMBARI-9046
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 2.0.0
>            Reporter: Oleg Nechiporenko
>            Assignee: Oleg Nechiporenko
>            Priority: Critical
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-9046.patch
>
>
> By default, ambari sets  templeton.hive.properties in webhcat-site as:
> {code}
> hive.metastore.local=false, hive.metastore.uris=thrift://ip-10-146-190-24.ec2.internal:9933,
hive.metastore.sasl.enabled=false, hive.metastore.execute.setugi=true
> {code}
> Two issues (see attached screen shot):
> 1) the spaces between the properties causes issue when using webhcat (like from hue or
pig view for example)
> 2) the  hive.metastore.uris component of that property looks incorrect. it has the wrong
port (compared to the actually property thrift://ip-10-146-190-24.ec2.internal:9083 which
is the value of property hive.metastore.uris)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message