ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yurii Shylov (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-8984) Ambari user+group sync does not work with Active Directory
Date Mon, 05 Jan 2015 11:21:34 GMT
Yurii Shylov created AMBARI-8984:
------------------------------------

             Summary: Ambari user+group sync does not work with Active Directory
                 Key: AMBARI-8984
                 URL: https://issues.apache.org/jira/browse/AMBARI-8984
             Project: Ambari
          Issue Type: Bug
          Components: ambari-server
    Affects Versions: 1.7.0
            Reporter: Yurii Shylov
            Assignee: Yurii Shylov
             Fix For: 2.0.0


Ambari LDAP sync does not work with AD where uid is set to null.

Steps to reproduce:

Try syncing ldap users from AD and you will see messages like:

{code}
17:19:42,915  WARN [pool-1-thread-1] AmbariLdapDataPopulator:560 - Ignoring LDAP user cn=Ambari
Admin,ou=Ambari,dc=SME,dc=support,dc=com as it doesn't have required attributes uid and sAMAccountName
17:20:38,375  WARN [pool-1-thread-2] AmbariLdapDataPopulator:560 - Ignoring LDAP user cn=testUser,ou=Ambari,dc=SME,dc=support,dc=com
as it doesn't have required attributes uid and sAMAccountName
17:21:47,387  WARN [pool-1-thread-3] AmbariLdapDataPopulator:560 - Ignoring LDAP user cn=testUser,ou=Ambari,dc=SME,dc=support,dc=com
as it doesn't have required attributes uid and sAMAccountName

{code}




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message