ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shiwei Guo (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-8706) [Building] got error npm ERR! phantomjs@1.9.12 install while building ambari-web
Date Wed, 14 Jan 2015 15:09:35 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-8706?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14277022#comment-14277022
] 

Shiwei Guo commented on AMBARI-8706:
------------------------------------

May because we are all behind the GFW

> [Building] got error npm ERR! phantomjs@1.9.12 install while building ambari-web
> --------------------------------------------------------------------------------
>
>                 Key: AMBARI-8706
>                 URL: https://issues.apache.org/jira/browse/AMBARI-8706
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 1.7.0
>         Environment: my host os version : ubuntu12.04.5
> building ambari from source  in docker platform with centos6.6
> docker version: Docker version 1.3.1, build 4e9bbfa
> CentOS version: CentOS release 6.6 (Final)
>            Reporter: Fuqing Yang
>
> I try to build ambari server from source in docker platform with Centos6.6.
> I do the building with reference at
> https://cwiki.apache.org/confluence/display/AMBARI/Ambari+Development .
> Tools needed to build Ambari have been installed sucessfully.
> I do the building as following:
> AMBARI_VERSION=1.7.0.0
> mvn versions:set -DnewVersion=${AMBARI_VERSION}
> (building command on CentOS)
> mvn -B clean install package rpm:rpm -DnewVersion=${AMBARI_VERSION} -DskipTests -Dpython.ver="python
>= 2.6" -Preplaceurl
> =====>error mesage:
>      [exec] > phantomjs@1.9.12 install /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/phantomjs
>      [exec] > node install.js
>      [exec] 
>      [exec] Downloading https://bitbucket.org/ariya/phantomjs/downloads/phantomjs-1.9.8-linux-x86_64.tar.bz2
>      [exec] Saving to /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/phantomjs/phantomjs/phantomjs-1.9.8-linux-x86_64.tar.bz2
>      [exec] Receiving...
>      [exec] Error making request.
>      [exec] Error: connect ETIMEDOUT
>      [exec]     at errnoException (net.js:904:11)
>      [exec]     at Object.afterConnect [as oncomplete] (net.js:895:19)
>      [exec] 
>      [exec] Please report this full log at https://github.com/Medium/phantomjs
>      [exec] 
>      [exec] 
>      [exec] > ws@0.4.32 install /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws
>      [exec] > (node-gyp rebuild 2> builderror.log) || (exit 0)
>      [exec] 
>      [exec] make: Entering directory `/docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws/build'
>      [exec]   CXX(target) Release/obj.target/bufferutil/src/bufferutil.o
>      [exec]   SOLINK_MODULE(target) Release/obj.target/bufferutil.node
>      [exec]   SOLINK_MODULE(target) Release/obj.target/bufferutil.node: Finished
>      [exec]   COPY Release/bufferutil.node
>      [exec]   CXX(target) Release/obj.target/validation/src/validation.o
>      [exec]   SOLINK_MODULE(target) Release/obj.target/validation.node
>      [exec] npm ERR! phantomjs@1.9.12 install: `node install.js`
>      [exec] npm ERR! Exit status 1
>      [exec] npm ERR! 
>      [exec] npm ERR! Failed at the phantomjs@1.9.12 install script.
>      [exec] npm ERR! This is most likely a problem with the phantomjs package,
>      [exec] npm ERR! not with npm itself.
>      [exec] npm ERR! Tell the author that this fails on your system:
>      [exec] npm ERR!     node install.js
>      [exec] npm ERR! You can get their info via:
>      [exec] npm ERR!     npm owner ls phantomjs
>      [exec] npm ERR! There is likely additional logging output above.
>      [exec] 
>      [exec] npm ERR! System Linux 3.13.0-32-generic
>      [exec] npm ERR! command "/docker_vol01/app/node-v0.10.33-bin/bin/node" "/docker_vol01/app/node-v0.10.33-bin/bin/npm"
"install"
>      [exec] npm ERR! cwd /docker_vol01/data/datadir_github/ambari/ambari-web
>      [exec] npm ERR! node -v v0.10.33
>      [exec] npm ERR! npm -v 1.4.28
>      [exec] npm ERR! code ELIFECYCLE
>      [exec]   SOLINK_MODULE(target) Release/obj.target/validation.node: Finished
>      [exec]   COPY Release/validation.node
>      [exec] make: Leaving directory `/docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws/build'
>      [exec] 
>      [exec] > ember-precompiler-brunch@1.4.1 postinstall /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/ember-precompiler-brunch
>      [exec] > node setup.js postinstall
>      [exec] 
>      [exec] npm ERR! not ok code 0
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO] 
> [INFO] Ambari Web ........................................ FAILURE [2:36.537s]
> [INFO] Ambari Views ...................................... SKIPPED
> [INFO] Ambari Admin View ................................. SKIPPED
> [INFO] Ambari Server ..................................... SKIPPED
> [INFO] Ambari Agent ...................................... SKIPPED
> [INFO] Ambari Client ..................................... SKIPPED
> [INFO] Ambari Python Client .............................. SKIPPED
> [INFO] Ambari Groovy Client .............................. SKIPPED
> [INFO] Ambari Shell ...................................... SKIPPED
> [INFO] Ambari Python Shell ............................... SKIPPED
> [INFO] Ambari Groovy Shell ............................... SKIPPED
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 2:37.559s
> [INFO] Finished at: Sun Dec 14 15:26:00 GMT 2014
> [INFO] Final Memory: 9M/101M
> [INFO] ------------------------------------------------------------------------
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.7:run (compile)
on project ambari-web: An Ant BuildException has occured: exec returned: 1
> [ERROR] around Ant part ...<exec dir="/docker_vol01/data/datadir_github/ambari/ambari-web"
executable="npm" failonerror="true">... @ 16:103 in /docker_vol01/data/datadir_github/ambari/ambari-web/target/antrun/build-ambari-web-compile.xml
> [ERROR] -> [Help 1]
> ######
> I search the error and found some suggestions at https://github.com/Medium/phantomjs#troubleshooting,
but tried them with not good luck.
> first, I check my network connection.
> ping bitbucket.org is OK.
> and get https://bitbucket.org/ariya/phantomjs/downloads/phantomjs-1.9.8-linux-x86_64.tar.bz2
in my brower sucessfully in manual.
> So, I change the PHANTOMJS_CDNURL(default is https://bitbucket.org/ariya/phantomjs/downloads)
> first trial: Failed after download http://cnpmjs.org/downloads/phantomjs-1.9.8-linux-x86_64.tar.bz2
> PHANTOMJS_CDNURL=http://cnpmjs.org/downloads
> export PHANTOMJS_CDNURL
> mvn -B clean install package rpm:rpm -DnewVersion=${AMBARI_VERSION} -DskipTests -Dpython.ver="python
>= 2.6" -Preplaceurl -rf :ambari-web
> =》error message:
>      [exec] > phantomjs@1.9.12 install /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/phantomjs
>      [exec] > node install.js
>      [exec] 
>      [exec] Downloading http://cnpmjs.org/downloads/phantomjs-1.9.8-linux-x86_64.tar.bz2
>      [exec] Saving to /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/phantomjs/phantomjs/phantomjs-1.9.8-linux-x86_64.tar.bz2
>      [exec] Receiving...
>      [exec] Error extracting archive
>      [exec] Phantom installation failed { [Error: spawn ENOENT] code: 'ENOENT', errno:
'ENOENT', syscall: 'spawn' } Error: spawn ENOENT
>      [exec]     at errnoException (child_process.js:1001:11)
>      [exec]     at Process.ChildProcess._handle.onexit (child_process.js:792:34)
>      [exec] 
>      [exec] Received 12854K total.
>      [exec] Extracting tar contents (via spawned process)
>      [exec] 
>      [exec] > ember-precompiler-brunch@1.4.1 postinstall /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/ember-precompiler-brunch
>      [exec] > node setup.js postinstall
>      [exec] 
>      [exec] 
>      [exec] > ws@0.4.32 install /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws
>      [exec] > (node-gyp rebuild 2> builderror.log) || (exit 0)
>      [exec] 
>      [exec] make: Entering directory `/docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws/build'
>      [exec]   CXX(target) Release/obj.target/bufferutil/src/bufferutil.o
>      [exec]   SOLINK_MODULE(target) Release/obj.target/bufferutil.node
>      [exec]   SOLINK_MODULE(target) Release/obj.target/bufferutil.node: Finished
>      [exec]   COPY Release/bufferutil.node
>      [exec]   CXX(target) Release/obj.target/validation/src/validation.o
>      [exec]   SOLINK_MODULE(target) Release/obj.target/validation.node
>      [exec] npm ERR! phantomjs@1.9.12 install: `node install.js`
>      [exec] npm ERR! Exit status 1
>      [exec] npm ERR! 
>      [exec] npm ERR! Failed at the phantomjs@1.9.12 install script.
>      [exec] npm ERR! This is most likely a problem with the phantomjs package,
>      [exec] npm ERR! not with npm itself.
>      [exec] npm ERR! Tell the author that this fails on your system:
>      [exec] npm ERR!     node install.js
>      [exec] npm ERR! You can get their info via:
>      [exec] npm ERR!     npm owner ls phantomjs
>      [exec] npm ERR! There is likely additional logging output above.
>      [exec] 
>      [exec] npm ERR! System Linux 3.13.0-32-generic
>      [exec] npm ERR! command "/docker_vol01/app/node-v0.10.33-bin/bin/node" "/docker_vol01/app/node-v0.10.33-bin/bin/npm"
"install"
>      [exec] npm ERR! cwd /docker_vol01/data/datadir_github/ambari/ambari-web
>      [exec] npm ERR! node -v v0.10.33
>      [exec] npm ERR! npm -v 1.4.28
>      [exec] npm ERR! code ELIFECYCLE
>      [exec]   SOLINK_MODULE(target) Release/obj.target/validation.node: Finished
>      [exec]   COPY Release/validation.node
>      [exec] make: Leaving directory `/docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws/build'
>      [exec] npm ERR! not ok code 0
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO] 
> [INFO] Ambari Web ........................................ FAILURE [39.775s]
> [INFO] Ambari Views ...................................... SKIPPED
> ......
> #####
> second trial: Failed in download request for http://cnpmjs.org/dist/phantomjs//phantomjs-1.9.8-linux-x86_64.tar.bz2.
(I check the network connection and it looks OK)
> PHANTOMJS_CDNURL=http://cnpmjs.org/dist/phantomjs/
> export PHANTOMJS_CDNURL
> mvn -B clean install package rpm:rpm -DnewVersion=${AMBARI_VERSION} -DskipTests -Dpython.ver="python
>= 2.6" -Preplaceurl -rf :ambari-web
> =>error message:
>      [exec] > phantomjs@1.9.12 install /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/phantomjs
>      [exec] > node install.js
>      [exec] 
>      [exec] Downloading http://cnpmjs.org/dist/phantomjs//phantomjs-1.9.8-linux-x86_64.tar.bz2
>      [exec] Saving to /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/phantomjs/phantomjs/phantomjs-1.9.8-linux-x86_64.tar.bz2
>      [exec] Receiving...
>      [exec] Error requesting archive.
>      [exec] Status: 404
>      [exec] Request options: {
>      [exec]   "uri": "http://cnpmjs.org/dist/phantomjs//phantomjs-1.9.8-linux-x86_64.tar.bz2",
>      [exec]   "encoding": null,
>      [exec]   "followRedirect": true,
>      [exec]   "headers": {},
>      [exec]   "strictSSL": false
>      [exec] }
>      [exec] Response headers: {
>      [exec]   "server": "nginx/1.4.6 (Ubuntu)",
>      [exec]   "date": "Sun, 14 Dec 2014 15:44:58 GMT",
>      [exec]   "content-type": "text/html; charset=utf-8",
>      [exec]   "content-length": "4208",
>      [exec]   "connection": "keep-alive",
>      [exec]   "x-powered-by": "koa",
>      [exec]   "x-readtime": "9"
>      [exec] }
>      [exec] Make sure your network and proxy settings are correct.
>      [exec] 
>      [exec] If you continue to have issues, please report this full log at https://github.com/Medium/phantomjs
>      [exec] 
>      [exec] 
>      [exec] 
>      [exec] > ember-precompiler-brunch@1.4.1 postinstall /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/ember-precompiler-brunch
>      [exec] > node setup.js postinstall
>      [exec] 
>      [exec] 
>      [exec] > ws@0.4.32 install /docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws
>      [exec] > (node-gyp rebuild 2> builderror.log) || (exit 0)
>      [exec] 
>      [exec] make: Entering directory `/docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws/build'
>      [exec]   CXX(target) Release/obj.target/bufferutil/src/bufferutil.o
>      [exec]   SOLINK_MODULE(target) Release/obj.target/bufferutil.node
>      [exec]   SOLINK_MODULE(target) Release/obj.target/bufferutil.node: Finished
>      [exec]   COPY Release/bufferutil.node
>      [exec]   CXX(target) Release/obj.target/validation/src/validation.o
>      [exec]   SOLINK_MODULE(target) Release/obj.target/validation.node
>      [exec]   SOLINK_MODULE(target) Release/obj.target/validation.node: Finished
>      [exec] npm ERR! phantomjs@1.9.12 install: `node install.js`
>      [exec] npm ERR! Exit status 1
>      [exec] npm ERR! 
>      [exec] npm ERR! Failed at the phantomjs@1.9.12 install script.
>      [exec] npm ERR! This is most likely a problem with the phantomjs package,
>      [exec] npm ERR! not with npm itself.
>      [exec] npm ERR! Tell the author that this fails on your system:
>      [exec] npm ERR!     node install.js
>      [exec] npm ERR! You can get their info via:
>      [exec] npm ERR!     npm owner ls phantomjs
>      [exec] npm ERR! There is likely additional logging output above.
>      [exec] 
>      [exec] npm ERR! System Linux 3.13.0-32-generic
>      [exec] npm ERR! command "/docker_vol01/app/node-v0.10.33-bin/bin/node" "/docker_vol01/app/node-v0.10.33-bin/bin/npm"
"install"
>      [exec] npm ERR! cwd /docker_vol01/data/datadir_github/ambari/ambari-web
>      [exec] npm ERR! node -v v0.10.33
>      [exec] npm ERR! npm -v 1.4.28
>      [exec] npm ERR! code ELIFECYCLE
>      [exec] npm ERR! not ok code 0
>      [exec]   COPY Release/validation.node
>      [exec] make: Leaving directory `/docker_vol01/data/datadir_github/ambari/ambari-web/node_modules/karma/node_modules/socket.io/node_modules/socket.io-client/node_modules/ws/build'
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO] 
> [INFO] Ambari Web ........................................ FAILURE [25.759s]
> [INFO] Ambari Views ...................................... SKIPPED
> ......
> I am confused with phantomjs problems.
> Any help would be appeciated.
> Is the following error still comming from the brokened network connection?
>      [exec] Phantom installation failed { [Error: spawn ENOENT] code: 'ENOENT', errno:
'ENOENT', syscall: 'spawn' } Error: spawn ENOENT
>      [exec]     at errnoException (child_process.js:1001:11)
>      [exec]     at Process.ChildProcess._handle.onexit (child_process.js:792:34)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message