ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom Beerbower (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (AMBARI-8342) Requesting the config_groups collection resource with no registered configuration groups results in a 404 response
Date Wed, 21 Jan 2015 20:28:34 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-8342?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tom Beerbower reassigned AMBARI-8342:
-------------------------------------

    Assignee: Tom Beerbower

> Requesting the config_groups collection resource with no registered configuration groups
results in a 404 response
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-8342
>                 URL: https://issues.apache.org/jira/browse/AMBARI-8342
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 1.7.0
>            Reporter: John Speidel
>            Assignee: Tom Beerbower
>              Labels: api
>             Fix For: 2.0.0
>
>
> GET http://AMBARI_HOST:8080/api/v1/clusters/c1/config_groups
> {
>   "status" : 404,
>   "message" : "The requested resource doesn't exist: ConfigGroup not found, ConfigGroup/cluster_name=c1"
> }
> The cluster c1 exists and has no configuration groups.  The above response is incorrect.
 As per the api specification, it should return an empty collection.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message