ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom Beerbower" <tbeerbo...@hortonworks.com>
Subject Re: Review Request 30188: Requesting the config_groups collection resource with no registered configuration groups results in a 404 response
Date Fri, 23 Jan 2015 00:26:08 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/30188/
-----------------------------------------------------------

(Updated Jan. 23, 2015, 12:26 a.m.)


Review request for Ambari and John Speidel.


Bugs: AMBARI-8342
    https://issues.apache.org/jira/browse/AMBARI-8342


Repository: ambari


Description
-------

GET http://AMBARI_HOST:8080/api/v1/clusters/c1/config_groups

{
  "status" : 404,
  "message" : "The requested resource doesn't exist: ConfigGroup not found, ConfigGroup/cluster_name=c1"
}

The cluster c1 exists and has no configuration groups.  The above response is incorrect. 
As per the api specification, it should return an empty collection.


Diffs (updated)
-----

  ambari-server/src/main/java/org/apache/ambari/server/api/query/QueryImpl.java 9f1be06 
  ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ClusterControllerImpl.java
b075d25 
  ambari-server/src/test/java/org/apache/ambari/server/api/query/QueryImplTest.java fdf3ef4

  ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ClusterControllerImplTest.java
fa24c9d 

Diff: https://reviews.apache.org/r/30188/diff/


Testing (updated)
-------

Manual test APIs to verify 404 and normal operation.
Added unit tests.

All tests pass.


Thanks,

Tom Beerbower


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message