ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley" <jhur...@hortonworks.com>
Subject Re: Review Request 29978: Parallel package installation under SLES misbehaves
Date Fri, 16 Jan 2015 22:06:58 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/29978/#review68482
-----------------------------------------------------------

Ship it!


Ship It!

- Jonathan Hurley


On Jan. 16, 2015, 3:07 p.m., Dmitro Lisnichenko wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/29978/
> -----------------------------------------------------------
> 
> (Updated Jan. 16, 2015, 3:07 p.m.)
> 
> 
> Review request for Ambari, Alejandro Fernandez, Jonathan Hurley, Nate Cole, and Yurii
Shylov.
> 
> 
> Bugs: AMBARI-9120
>     https://issues.apache.org/jira/browse/AMBARI-9120
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> Both issues reproduce only under SLES SP3, and don't reproduce under SLES SP1
> 
> The first issue:
> When installing second stack version in parallel, dependencies for the second stack version
are not installed
> 
> The second issue:
> When trying to install older stack version in parallel with newer stack version, zypper
refuses to install packages even through it has been restricted to relevant repositories.
Looks like we have to append concrete repo versions before asterisk at globs like hadoop_2_2_*
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/java/org/apache/ambari/server/events/listeners/upgrade/DistributeRepositoriesActionListener.java
da6e680 
>   ambari-server/src/main/resources/custom_actions/scripts/install_packages.py 83c8037

>   ambari-server/src/test/python/custom_actions/TestInstallPackages.py 0ad56c8 
> 
> Diff: https://reviews.apache.org/r/29978/diff/
> 
> 
> Testing
> -------
> 
> manual tests under SLES SP1 and SLES SP3. Installed only few basic services for now.
Performing more full-pledged tests.
> 
> Unit tests pass except the unrelated test fail (also fails on trunk)
> 
> ----------------------------------------------------------------------
> Failed tests:
> FAIL: test_prompt_db_properties_for_each_database_type (TestAmbariServer.TestAmbariServer)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File "/media/plextor/ambari/ambari-common/src/test/python/mock/mock.py", line 1199,
in patched
>     return func(*args, **keywargs)
>   File "/media/plextor/ambari/ambari-server/src/test/python/TestAmbariServer.py", line
2370, in test_prompt_db_properties_for_each_database_type
>     self.assertFalse(_ambari_server_.JDBC_POSTGRES_SCHEMA_PROPERTY in properties.propertyNames())
> AssertionError: True is not false
> 
> ----------------------------------------------------------------------
> Total run:585
> Total errors:0
> Total failures:1
> ERROR
> 
> 
> Thanks,
> 
> Dmitro Lisnichenko
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message