ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Cole" <nc...@hortonworks.com>
Subject Re: Review Request 29767: Ambari Builds Succeed With Python Unit Test Failures
Date Fri, 09 Jan 2015 16:49:35 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/29767/#review67448
-----------------------------------------------------------

Ship it!



ambari-server/src/test/python/custom_actions/TestInstallPackages.py
<https://reviews.apache.org/r/29767/#comment111472>

    Strange that you don't need the u' here for repo_template, but you do in the other test
methods that do the same check.


- Nate Cole


On Jan. 9, 2015, 11:30 a.m., Jonathan Hurley wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/29767/
> -----------------------------------------------------------
> 
> (Updated Jan. 9, 2015, 11:30 a.m.)
> 
> 
> Review request for Ambari, Nate Cole and Tom Beerbower.
> 
> 
> Bugs: AMBARI-9063
>     https://issues.apache.org/jira/browse/AMBARI-9063
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> The Ambari builds are succeeding locally and on builds.apache.org even though the trunk
currently has failures on python tests. See
> 
> https://builds.apache.org/view/All/job/Ambari-trunk-Commit/1441/consoleFull
> 
> And search for "Total run:570"
> 
> It looks like the root cause of this is that the python test runner is reporting an OK
with failures:
> 
> {noformat}
> $ python unitTests.py
> ...
> 
> ----------------------------------------------------------------------
> Total run:569
> Total errors:0
> Total failures:4
> OK
> {noformat}
> 
> The problem is that the python test runner is reporting a success:
> {code}
> tests_status = textRunner.wasSuccessful() and not has_failures
> {code}
> 
> {code}
> print textRunner.wasSuccessful()
> True
> 
> print has_failures
> False
> {code}
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/test/python/custom_actions/TestCheckHost.py cb934c9 
>   ambari-server/src/test/python/custom_actions/TestInstallPackages.py beb918b 
>   ambari-server/src/test/python/unitTests.py 7c9f089 
> 
> Diff: https://reviews.apache.org/r/29767/diff/
> 
> 
> Testing
> -------
> 
> OK
> ----------------------------------------------------------------------
> Total run:570
> Total errors:0
> Total failures:0
> OK
> 
> Verified that causing tests to fail in ambari-server and custom-actions causes the build
to fail as well.
> 
> 
> Thanks,
> 
> Jonathan Hurley
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message