ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Fernandez (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-8848) hdp-select set all <version> uses 2.2.0.0 instead of 2.2
Date Sat, 20 Dec 2014 03:36:13 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-8848?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alejandro Fernandez updated AMBARI-8848:
----------------------------------------
    Attachment:     (was: AMBARI-8848.patch)

> hdp-select set all <version> uses 2.2.0.0 instead of 2.2
> --------------------------------------------------------
>
>                 Key: AMBARI-8848
>                 URL: https://issues.apache.org/jira/browse/AMBARI-8848
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-server
>    Affects Versions: 1.7.0
>            Reporter: Alejandro Fernandez
>            Assignee: Alejandro Fernandez
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-8848.patch
>
>
> 'sudo /usr/bin/hdp-select set all `ambari-python-wrap /usr/bin/hdp-select versions |
grep ^2.2.0.0 | tail -1`' will always use 2.2.0.0 because it tries to format 2.2 to have 4
digits by right-padding with 0s. This causes the hdp-select set all to not function when installing
HDP 2.2.1 stack.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message