ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Lysnichenko (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-8639) Distribute Repository/Install: parallel install not working
Date Wed, 10 Dec 2014 15:46:12 GMT
Dmitry Lysnichenko created AMBARI-8639:
------------------------------------------

             Summary: Distribute Repository/Install: parallel install not working
                 Key: AMBARI-8639
                 URL: https://issues.apache.org/jira/browse/AMBARI-8639
             Project: Ambari
          Issue Type: Task
          Components: ambari-server
    Affects Versions: 2.0.0
            Reporter: Dmitry Lysnichenko
            Assignee: Dmitry Lysnichenko
             Fix For: 2.0.0


As of Dec 9.

* Installed a brand new cluster from trunk.
* Installed initial repository with no issue of 2.2.0.0-2041.
* This created repo files HDP.repo and HDP-UTILS.repo on each host.
* All green.

Then, attempted creation of a new version.  Custom Action invoked successfully, but the result
failed.

1. For HDP, ended up with two files:  HDP.repo and HDP-2.2.repo.  Each file contained a repo
named "HDP-2.2".  The output of the yum invokation contains:

{noformat}
2014-12-09 19:19:54,929 - Package['zookeeper_2_2_*'] {}
2014-12-09 19:19:55,300 - Skipping installing existent package zookeeper_2_2_*
{noformat}
which should definitely NOT happen.

2.  The name of the repository file should be a little more specific.  There may be several
"HDP-2.2" that a cluster is upgraded to.
3.  The installation should use ONLY the repo designated that it just created, such that we
know that the version installed is from the correct repo.  The command should be something
like: {{yum install --disablerepo=* --enablerepo="HDP-2.2.0.0-1234" zookeeper_2_2_*}}




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message