ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Levas (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-8578) Update Apache Directory Server Library from 1.5.5 to 2.0.0-M19
Date Mon, 08 Dec 2014 17:18:12 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-8578?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Levas updated AMBARI-8578:
---------------------------------
    Attachment: AMBARI-8578_02.patch

Changed Ambari Directory Service version from M17 to M19.

Patch File [^AMBARI-8578_02.patch]

> Update Apache Directory Server Library from 1.5.5 to 2.0.0-M19
> --------------------------------------------------------------
>
>                 Key: AMBARI-8578
>                 URL: https://issues.apache.org/jira/browse/AMBARI-8578
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-server
>    Affects Versions: 2.0.0
>            Reporter: Robert Levas
>            Assignee: Robert Levas
>              Labels: apacheds, kerberos, ldap
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-8578_01.patch, AMBARI-8578_02.patch
>
>
> Update Apache Directory Server Library from 1.5.5 to 2.0.0-M19 to obtain bug fixes needed
for future patches. 
> One fix in particular is DIRSERVER-1882 (https://issues.apache.org/jira/browse/DIRSERVER-1882).
> Currently, the only dependency on this library are unit test cases:
> * org.apache.ambari.server.security.authorization.AmbariLdapAuthenticationProviderTest
> * org.apache.ambari.server.security.authorization.AmbariLdapAuthenticationProviderForDNWithSpaceTest
> * org.apache.ambari.server.security.authorization.AmbariLdapAuthenticationProviderBaseTest
> These need to be updated to support the new library and associated dependencies. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message