ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-8508) Deleting all zookeeper servers and adding one again is not updating Hbase config properly
Date Tue, 02 Dec 2014 15:49:13 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-8508?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14231667#comment-14231667
] 

Hudson commented on AMBARI-8508:
--------------------------------

FAILURE: Integrated in Ambari-trunk-Commit-docker #356 (See [https://builds.apache.org/job/Ambari-trunk-Commit-docker/356/])
AMBARI-8508. Deleting all zookeeper servers and adding one again is not updating Hbase config
properly (onechiporenko) (onechiporenko: http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=15343acd852f7bae43e282b14764ed19ed3ab5f9)
* ambari-web/app/controllers/main/host/details.js
* ambari-web/test/controllers/main/host/details_test.js
* ambari-web/app/mappers/service_metrics_mapper.js


> Deleting all zookeeper servers and adding one again is not updating Hbase config properly
> -----------------------------------------------------------------------------------------
>
>                 Key: AMBARI-8508
>                 URL: https://issues.apache.org/jira/browse/AMBARI-8508
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 2.0.0
>            Reporter: Oleg Nechiporenko
>            Assignee: Oleg Nechiporenko
>             Fix For: 2.0.0
>
>         Attachments: AMBARI-8508.patch, UI_part_of_configs.png
>
>
> on removing all zookeeper servers and then adding 1 to a host does not update hbase-core-site.xml
hbase..zookeeper.quorum  property appropriately.
> the following test steps were followed on my vagrant cluster to reproduce:
> 1. Vagrant cluster with 4 nodes of which 3 had zookeerper server installed and 2 zookeeper
clients
> 2. Remove zookeeper from one host and verify hbase config. The property is correctly
updated
> 3. remove zookeeper from all hosts and add it to the host on which it did not exist earlier
> 4. Start zookeeper server
> 5. verify hbase config for zookeeper again.
> Expected: only one host with the zookeeper server should be listed in value for the hbase
config hbase.zookeeper.quorum
> Actual: at least 2 host are listed and one of which does not have any zookeeper server
on it.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message