ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-8473) Ambari public hostname script doesn't work
Date Fri, 28 Nov 2014 16:02:12 GMT
Andrew Onischuk created AMBARI-8473:
---------------------------------------

             Summary: Ambari public hostname script doesn't work
                 Key: AMBARI-8473
                 URL: https://issues.apache.org/jira/browse/AMBARI-8473
             Project: Ambari
          Issue Type: Bug
            Reporter: Andrew Onischuk
            Assignee: Andrew Onischuk
             Fix For: 2.0.0


PROBLEM: follow the instruction to specify the public hostname, configure it
in ambari-agent.ini. When it restart ambari-agent, the follow error is
observed:

    
    
    INFO 2014-11-24 19:23:58,190 NetUtil.py:49 - Calling url received 200
    INFO 2014-11-24 19:23:58,196 hostname.py:75 - Error using the scriptname:Traceback (most
recent call last):
      File "/usr/lib/python2.6/site-packages/ambari_agent/hostname.py", line 66, in public_hostname
        output = subprocess.Popen([scriptname],stdout=subprocess.PIPE, stderr=subprocess.PIPE,
cwd='/')
      File "/usr/lib64/python2.6/subprocess.py", line 642, in __init__
        errread, errwrite)
      File "/usr/lib64/python2.6/subprocess.py", line 1234, in _execute_child
        raise child_exception
    OSError: [Errno 2] No such file or directory
     :out  :err
    

In ambari-agent.ini:  
we have public_hostname_script=/var/lib/ambari-agent/hostname.sh

and permission is 777.

The hosts table in database is not updated as well.





--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message