ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yurii Shylov (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-8211) Repository Version Management - Create API and BE support for update/delete repository version
Date Fri, 07 Nov 2014 17:33:33 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-8211?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Yurii Shylov updated AMBARI-8211:
---------------------------------
    Description: 
Create the following API:
{code}
DELETE /api/v1/repository_versions/1
{code}

{code}
PUT /api/v1/repository_versions/1
{
  "RepositoryVersion": {
    "id": "1",
    "display_name": "HDP-2.2 latest build",
    "upgrade_pack": "xyz",
    "repositories": [
      {
        "os": "redhat6",
        "baseurls": [
          {
            "id": "HDP-2.2.0.1-885",
            "type": "HDP",
            "baseurl": "http://host1/hdp"
          },
          {
            "id": "HDP-UTILS-1.0.0.20",
            "type": "HDP-UTILS",
            "baseurl": "http://host1/hdp-utils"
          }
        ]
      }
    ]
}
{code}
(stack and its version should not be updatable yet)

Both APIs should not work if Repository Version is INSTALLED or CURRENT on any of the clusters.

  was:
Create the following API:
{code}
DELETE /api/v1/repository_versions/1
{code}

{code}
PUT /api/v1/repository_versions/1
{
  "RepositoryVersion": {
    "id": "1",
    "display_name": "HDP-2.2 latest build",
    "upgrade_pack": "xyz",
    "repositories": [
      {
        "os": "redhat6",
        "baseurls": [
          {
            "id": "HDP-2.2.0.1-885",
            "type": "HDP",
            "baseurl": "http://host1/hdp"
          },
          {
            "id": "HDP-UTILS-1.0.0.20",
            "type": "HDP-UTILS",
            "baseurl": "http://host1/hdp-utils"
          }
        ]
      }
    ]
}
{code}
(stack and it's version should not be updatable yet)

Both APIs should not work if Repository Version is INSTALLED or CURRENT on any of the clusters.


> Repository Version Management - Create API and BE support for update/delete repository
version
> ----------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-8211
>                 URL: https://issues.apache.org/jira/browse/AMBARI-8211
>             Project: Ambari
>          Issue Type: Technical task
>          Components: ambari-server
>    Affects Versions: 2.0.0
>            Reporter: Yurii Shylov
>            Assignee: Yurii Shylov
>             Fix For: 2.0.0
>
>
> Create the following API:
> {code}
> DELETE /api/v1/repository_versions/1
> {code}
> {code}
> PUT /api/v1/repository_versions/1
> {
>   "RepositoryVersion": {
>     "id": "1",
>     "display_name": "HDP-2.2 latest build",
>     "upgrade_pack": "xyz",
>     "repositories": [
>       {
>         "os": "redhat6",
>         "baseurls": [
>           {
>             "id": "HDP-2.2.0.1-885",
>             "type": "HDP",
>             "baseurl": "http://host1/hdp"
>           },
>           {
>             "id": "HDP-UTILS-1.0.0.20",
>             "type": "HDP-UTILS",
>             "baseurl": "http://host1/hdp-utils"
>           }
>         ]
>       }
>     ]
> }
> {code}
> (stack and its version should not be updatable yet)
> Both APIs should not work if Repository Version is INSTALLED or CURRENT on any of the
clusters.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message