ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitry Lysnichenko (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-7862) Storm doesn't start in ambari
Date Mon, 20 Oct 2014 14:34:33 GMT
Dmitry Lysnichenko created AMBARI-7862:
------------------------------------------

             Summary: Storm doesn't start in ambari
                 Key: AMBARI-7862
                 URL: https://issues.apache.org/jira/browse/AMBARI-7862
             Project: Ambari
          Issue Type: Bug
          Components: ambari-server
    Affects Versions: 1.7.0
            Reporter: Dmitry Lysnichenko
            Assignee: Dmitry Lysnichenko
             Fix For: 1.7.0


ambari server a410ca3b8f27412140553e8cfc2a2392154af0c9
storm.nimbus.childopts has:
-Xmx1024m _JAAS_PLACEHOLDER -javaagent:/usr/hdp/current/storm-nimbus/contrib/storm-jmxetric/lib/jmxetric-1.0.4.jar=host=c6402.ambari.apache.org,port=8649,wireformat31x=true,mode=multicast,config=/usr/hdp-nimbus/current/storm-client/contrib/storm-jmxetric/conf/jmxetric-conf.xml,process=Nimbus_JVM
Please change /usr/hdp-nimbus to /usr/hdp
after fixing the above ambari doesn't recognize if the service started because its using following

pgrep -f "^java.+backtype.storm.ui.core$" && pgrep -f "^java.+backtype.storm.ui.core$"

since those texts are not in process list it won't find that the service is started



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message