ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-7860) Download client configs not working, returns 404
Date Mon, 20 Oct 2014 19:13:34 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-7860?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14177330#comment-14177330
] 

Hudson commented on AMBARI-7860:
--------------------------------

SUCCESS: Integrated in Ambari-trunk-Commit #640 (See [https://builds.apache.org/job/Ambari-trunk-Commit/640/])
AMBARI-7860. Download client configs not working, returns 404 (dlysnichenko) (dlysnichenko:
http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=47929dce2e854a5ee1ad7944da83d90545c517da)
* ambari-server/src/test/java/org/apache/ambari/server/controller/internal/ClientConfigResourceProviderTest.java
* ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ClientConfigResourceProvider.java


> Download client configs not working, returns 404
> ------------------------------------------------
>
>                 Key: AMBARI-7860
>                 URL: https://issues.apache.org/jira/browse/AMBARI-7860
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 1.7.0
>            Reporter: Dmitry Lysnichenko
>            Assignee: Dmitry Lysnichenko
>             Fix For: 1.7.0
>
>         Attachments: AMBARI-7860.patch
>
>
> In Ambari 1.7.0, going to any installed service and attempting to download its client
configs from the website is not working.
> Example of requests sent,
> http://c6404.ambari.apache.org:8080/api/v1/clusters/dev/services/TEZ/components/TEZ_CLIENT?format=client_config_tar
> http://c6404.ambari.apache.org:8080/api/v1/clusters/dev/services/HDFS/components/HDFS_CLIENT?format=client_config_tar
> which returns
> {code}
> {
>   "status" : 404,
>   "message" : "The requested resource doesn't exist: ClientConfig not found, ServiceComponentInfo/service_name=HDFS
AND ServiceComponentInfo/component_name=HDFS_CLIENT AND ServiceComponentInfo/cluster_name=dev"
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message