ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-7860) Download client configs not working, returns 404
Date Mon, 20 Oct 2014 15:16:33 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-7860?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14176964#comment-14176964
] 

Hadoop QA commented on AMBARI-7860:
-----------------------------------

{color:green}+1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12675828/AMBARI-7860.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 1 new or modified
test files.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in ambari-server.

Test results: https://builds.apache.org/job/Ambari-trunk-test-patch/259//testReport/
Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/259//console

This message is automatically generated.

> Download client configs not working, returns 404
> ------------------------------------------------
>
>                 Key: AMBARI-7860
>                 URL: https://issues.apache.org/jira/browse/AMBARI-7860
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 1.7.0
>            Reporter: Dmitry Lysnichenko
>            Assignee: Dmitry Lysnichenko
>             Fix For: 1.7.0
>
>         Attachments: AMBARI-7860.patch
>
>
> In Ambari 1.7.0, going to any installed service and attempting to download its client
configs from the website is not working.
> Example of requests sent,
> http://c6404.ambari.apache.org:8080/api/v1/clusters/dev/services/TEZ/components/TEZ_CLIENT?format=client_config_tar
> http://c6404.ambari.apache.org:8080/api/v1/clusters/dev/services/HDFS/components/HDFS_CLIENT?format=client_config_tar
> which returns
> {code}
> {
>   "status" : 404,
>   "message" : "The requested resource doesn't exist: ClientConfig not found, ServiceComponentInfo/service_name=HDFS
AND ServiceComponentInfo/component_name=HDFS_CLIENT AND ServiceComponentInfo/cluster_name=dev"
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message