ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Siddharth Wagle (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-7683) Upgrade: 1.6.1 fails to upgrade with LDAP configured w/o encrypt pwds
Date Wed, 08 Oct 2014 00:14:33 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-7683?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Siddharth Wagle updated AMBARI-7683:
------------------------------------
    Issue Type: Bug  (was: Task)

> Upgrade: 1.6.1 fails to upgrade with LDAP configured w/o encrypt pwds
> ---------------------------------------------------------------------
>
>                 Key: AMBARI-7683
>                 URL: https://issues.apache.org/jira/browse/AMBARI-7683
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 1.7.0
>            Reporter: Siddharth Wagle
>            Assignee: Siddharth Wagle
>             Fix For: 1.7.0
>
>
> 1) Install Ambari 1.6.1, embedded postgres.
> 2) Install + configure HDP 2.1 Stack cluster
> 3) ambari-server setup-ldap, test authentication with a couple accounts
> 4) attempt upgrade to ambari 1.7.0, upgrade fails
> {code}
> 20:15:23,439 ERROR [main] SchemaUpgradeHelper:252 - Exception occured during upgrade,
>  failed
> org.apache.ambari.server.AmbariException: Guice provision errors:
> 1) Error injecting constructor, java.lang.RuntimeException: Unable to read database p
> assword
>   at org.apache.ambari.server.security.ldap.AmbariLdapDataPopulator.<init>(AmbariLdap
> DataPopulator.java:95)
>   while locating org.apache.ambari.server.security.ldap.AmbariLdapDataPopulator
>     for field at org.apache.ambari.server.controller.AmbariManagementControllerImpl.l
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message