ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yusaku Sako (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-7616) Cannot run build as root
Date Thu, 02 Oct 2014 22:11:34 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-7616?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14157289#comment-14157289
] 

Yusaku Sako commented on AMBARI-7616:
-------------------------------------

+1 for the patch.

> Cannot run build as root 
> -------------------------
>
>                 Key: AMBARI-7616
>                 URL: https://issues.apache.org/jira/browse/AMBARI-7616
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-admin
>    Affects Versions: 1.7.0
>            Reporter: Yusaku Sako
>            Assignee: Jaimin D Jetly
>             Fix For: 1.7.0
>
>         Attachments: AMBARI-7616.patch
>
>
> [DEBUG]   (f) nodeVersion = v0.10.26
> [DEBUG]   (f) npmVersion = 1.4.3
> [DEBUG]   (f) session = org.apache.maven.execution.MavenSession@f8b7298
> [DEBUG]   (f) workingDirectory = /root/102/ambari/ambari-admin/src/main/resources/ui/admin-web
> [DEBUG] -- end configuration --
> [INFO] Node v0.10.26 is already installed.
> [INFO] Found NPM version 1.4.3
> [INFO]
> [INFO] --- frontend-maven-plugin:0.0.14:npm (npm install) @ ambari-admin ---
> [DEBUG] Configuring mojo com.github.eirslett:frontend-maven-plugin:0.0.14:npm from plugin
realm ClassRealm[plugin>com.github.eirslett:frontend-maven-plugin:0.0.14, parent: sun.misc.Launcher$AppClassLoader@138d107f]
> [DEBUG] Configuring mojo 'com.github.eirslett:frontend-maven-plugin:0.0.14:npm' with
basic configurator -->
> [DEBUG]   (f) arguments = install --unsafe-perm
> [DEBUG]   (f) workingDirectory = /root/102/ambari/ambari-admin/src/main/resources/ui/admin-web
> [DEBUG] -- end configuration --
> [INFO] Running 'npm install --unsafe-perm --color=false' in /root/102/ambari/ambari-admin/src/main/resources/ui/admin-web
> [INFO] npm WARN package.json adminconsole@0.0.0 No description
> [INFO] npm WARN package.json adminconsole@0.0.0 No repository field.
> [INFO] npm WARN package.json adminconsole@0.0.0 No README data
> [INFO]
> [INFO] > adminconsole@0.0.0 postinstall /root/102/ambari/ambari-admin/src/main/resources/ui/admin-web
> [INFO] > bower install
> [INFO]
> [INFO] bower ESUDO         Cannot be run with sudo
> [INFO]
> [INFO] Additional error details:
> [INFO] Since bower is a user command, there is no need to execute it with superuser permissions.
> [INFO] If you're having permission errors when using bower without sudo, please spend
a few minutes learning more about how your system should work and make any necessary repairs.
> [INFO]
> [INFO] http://www.joyent.com/blog/installing-node-and-npm
> [INFO] https://gist.github.com/isaacs/579814
> [INFO]
> [INFO] You can however run a command with sudo using --allow-root option
> [INFO]
> [INFO] npm ERR! adminconsole@0.0.0 postinstall: `bower install`
> [INFO] npm ERR! Exit status 1
> [INFO] npm ERR!
> [INFO] npm ERR! Failed at the adminconsole@0.0.0 postinstall script.
> [INFO] npm ERR! This is most likely a problem with the adminconsole package,
> [INFO] npm ERR! not with npm itself.
> [INFO] npm ERR! Tell the author that this fails on your system:
> [INFO] npm ERR!     bower install
> [INFO] npm ERR! You can get their info via:
> [INFO] npm ERR!     npm owner ls adminconsole
> [INFO] npm ERR! There is likely additional logging output above.
> [INFO] npm ERR! System Linux 2.6.32-431.20.3.el6.x86_64
> [INFO] npm ERR! command "/root/102/ambari/ambari-admin/src/main/resources/ui/admin-web/node/node"
"/root/102/ambari/ambari-admin/src/main/resources/ui/admin-web/node/npm/bin/npm-cli.js" "install"
"--unsafe-perm" "--color=false"
> [INFO] npm ERR! cwd /root/102/ambari/ambari-admin/src/main/resources/ui/admin-web
> [INFO] npm ERR! node -v v0.10.26
> [INFO] npm ERR! npm -v 1.4.3
> [INFO] npm ERR! code ELIFECYCLE
> [INFO] npm ERR!
> [INFO] npm ERR! Additional logging details can be found in:
> [INFO] npm ERR!     /root/102/ambari/ambari-admin/src/main/resources/ui/admin-web/npm-debug.log
> [INFO] npm ERR! not ok code 0
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] Ambari Main ....................................... SUCCESS [11.055s]
> [INFO] Apache Ambari Project POM ......................... SUCCESS [1.346s]
> [INFO] Ambari Web ........................................ SUCCESS [1:58.936s]
> [INFO] Ambari Views ...................................... SUCCESS [13.178s]
> [INFO] Ambari Admin View ................................. FAILURE [3.873s]
> [INFO] Ambari Server ..................................... SKIPPED
> [INFO] Ambari Agent ...................................... SKIPPED
> [INFO] Ambari Client ..................................... SKIPPED
> [INFO] Ambari Python Client .............................. SKIPPED
> [INFO] Ambari Groovy Client .............................. SKIPPED
> [INFO] Ambari Shell ...................................... SKIPPED
> [INFO] Ambari Python Shell ............................... SKIPPED
> [INFO] Ambari Groovy Shell ............................... SKIPPED
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 2:31.656s
> [INFO] Finished at: Sat Sep 27 00:22:41 EDT 2014
> [INFO] Final Memory: 23M/56M
> [INFO] ------------------------------------------------------------------------
> [ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.14:npm (npm
install) on project ambari-admin: 'npm install --unsafe-perm --color=false' failed. (error
code 1) -> [Help 1]
> org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.14:npm
(npm install) on project ambari-admin: 'npm install --unsafe-perm --color=false' failed. (error
code 1)
>         at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:213)
>         at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
>         at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
>         at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
>         at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
>         at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
>         at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
>         at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
>         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
>         at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
>         at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
>         at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>         at java.lang.reflect.Method.invoke(Method.java:597)
>         at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
>         at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
>         at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
>         at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
> Caused by: org.apache.maven.plugin.MojoFailureException: 'npm install --unsafe-perm --color=false'
failed. (error code 1)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message