ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-7613) Ambari installs wrong zookeeper_client_jaas.conf file.
Date Thu, 02 Oct 2014 14:03:33 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-7613?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Onischuk resolved AMBARI-7613.
-------------------------------------
    Resolution: Fixed

Committed to trunk

> Ambari installs wrong zookeeper_client_jaas.conf file.
> ------------------------------------------------------
>
>                 Key: AMBARI-7613
>                 URL: https://issues.apache.org/jira/browse/AMBARI-7613
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 1.7.0
>
>
> PROBLEM:
> Ambari 1.6.1,
> /var/lib/ambari-server/resources/stacks/HDP/2.0.6/services/ZOOKEEPER/package/t
> emplates/zookeeper_client_jaas.conf.js2
>     
>     
>     
>     Client {
>     com.sun.security.auth.module.Krb5LoginModule required
>     useKeyTab=false
>     useTicketCache=true;
>     principal="{{zk_principal}}";
>     };
>     
>     
> The above config is wrong. The correct file should be
>     
>     
>     
>     
>     Client {
>     com.sun.security.auth.module.Krb5LoginModule required
>     useKeyTab=false
>     useTicketCache=true;
>     };
>     
>     
> Note, the principal=xxx should not be there when useTicketCache=true



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message