ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Denissov <adenis...@pivotal.io>
Subject Re: Unable to build RPM for ambari Server
Date Mon, 06 Oct 2014 23:25:29 GMT
Using the updated version of node (0.10.31) still results in build failures
on the Vagrant image (centos 6.4) -- see section1 below.

I noticed that
https://github.com/apache/ambari/blob/trunk/ambari-admin/pom.xml specifies
node version as 0.10.26. Changing this value to 0.10.31 still produces an
error (section 2)

SECTION 1 -- without change to pom.xml

bower sinon#~1.10.3                   resolved git://
github.com/cjohansen/Sinon.JS.git#1.10.3
bower                                ECONFLICT Unable to find suitable
version for angular
[INFO]
------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] Ambari Main ....................................... SUCCESS [5.254s]
[INFO] Apache Ambari Project POM ......................... SUCCESS [0.567s]
[INFO] Ambari Web ........................................ SUCCESS
[1:21.776s]
[INFO] Ambari Views ...................................... SUCCESS
[1:02.487s]
[INFO] Ambari Admin View ................................. FAILURE
[1:26.446s]
[INFO] Ambari Server ..................................... SKIPPED
[INFO] Ambari Agent ...................................... SKIPPED
[INFO] Ambari Client ..................................... SKIPPED
[INFO] Ambari Python Client .............................. SKIPPED
[INFO] Ambari Groovy Client .............................. SKIPPED
[INFO] Ambari Shell ...................................... SKIPPED
[INFO] Ambari Python Shell ............................... SKIPPED
[INFO] Ambari Groovy Shell ............................... SKIPPED
[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 3:57.899s
[INFO] Finished at: Mon Oct 06 22:35:32 UTC 2014
[INFO] Final Memory: 24M/59M
[INFO]
------------------------------------------------------------------------
[ERROR] Failed to execute goal org.codehaus.mojo:exec-maven-plugin:1.3.2:exec
(Bower install) on project ambari-admin: Command execution failed. Process
exited with an error: 1 (Exit value: 1) -> [Help 1]

SECTION 2 -- after the change to pom.xml -- gets a bit further, but still
fails on angular:

bower sinon#~1.10.3           validate 1.10.3 against git://
github.com/cjohansen/Sinon.JS.git#~1.10.3
bower angular#~1.2.25           cached git://
github.com/angular/bower-angular.git#1.2.26
bower angular#~1.2.25         validate 1.2.26 against git://
github.com/angular/bower-angular.git#~1.2.25
bower angular-route#~1.2.25     cached git://
github.com/angular/bower-angular-route.git#1.2.26
bower angular-route#~1.2.25   validate 1.2.26 against git://
github.com/angular/bower-angular-route.git#~1.2.25
bower angular#1.2.25            cached git://
github.com/angular/bower-angular.git#1.2.25
bower angular#1.2.25          validate 1.2.25 against git://
github.com/angular/bower-angular.git#1.2.25
bower angular#>=1               cached git://
github.com/angular/bower-angular.git#1.2.26
bower angular#>=1             validate 1.2.26 against git://
github.com/angular/bower-angular.git#>=1
bower angular#*                 cached git://
github.com/angular/bower-angular.git#1.2.26
bower angular#*               validate 1.2.26 against git://
github.com/angular/bower-angular.git#*
bower angular-animate#~1.2.25   cached git://
github.com/angular/bower-angular-animate.git#1.2.26
bower angular-animate#~1.2.25 validate 1.2.26 against git://
github.com/angular/bower-angular-animate.git#~1.2.25
bower angular#1.2.26            cached git://
github.com/angular/bower-angular.git#1.2.26
bower angular#1.2.26          validate 1.2.26 against git://
github.com/angular/bower-angular.git#1.2.26
bower                        ECONFLICT Unable to find suitable version for
angular
[INFO]
------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] Ambari Main ....................................... SUCCESS [13.244s]
[INFO] Apache Ambari Project POM ......................... SUCCESS [1.953s]
[INFO] Ambari Web ........................................ SUCCESS
[1:22.474s]
[INFO] Ambari Views ...................................... SUCCESS [10.258s]
[INFO] Ambari Admin View ................................. FAILURE [6.129s]
[INFO] Ambari Server ..................................... SKIPPED
[INFO] Ambari Agent ...................................... SKIPPED
[INFO] Ambari Client ..................................... SKIPPED
[INFO] Ambari Python Client .............................. SKIPPED
[INFO] Ambari Groovy Client .............................. SKIPPED
[INFO] Ambari Shell ...................................... SKIPPED
[INFO] Ambari Python Shell ............................... SKIPPED
[INFO] Ambari Groovy Shell ............................... SKIPPED
[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 1:56.179s
[INFO] Finished at: Mon Oct 06 23:10:35 UTC 2014
[INFO] Final Memory: 26M/64M
[INFO]
------------------------------------------------------------------------
[ERROR] Failed to execute goal
org.codehaus.mojo:exec-maven-plugin:1.3.2:exec (Bower install) on project
ambari-admin: Command execution failed. Process exited with an error: 1
(Exit value: 1) -> [Help 1]

On Mon, Oct 6, 2014 at 3:11 PM, Yusaku Sako <yusaku@hortonworks.com> wrote:

> BTW, dev-bootstrap.sh for centos6.5 has just been updated to use Node
> 0.10.31.
>
> Thanks,
> Yusaku
>
> On Mon, Oct 6, 2014 at 1:45 PM, Yusaku Sako <yusaku@hortonworks.com>
> wrote:
>
> > Hi Rodrigo,
> >
> > What OS are you using?
> > It looks like the VM is using Node 0.10.15.  This will not work.
> > We need to modify dev-bootstrap.sh to download 0.10.31 instead.
> > This was already done for centos6.4, but not for other OS's.
> >
> > Yusaku
> >
> >
> > On Mon, Oct 6, 2014 at 1:40 PM, Rodrigo Meneses <rmeneses@pivotal.io>
> > wrote:
> >
> >> Hello,
> >>
> >> I tried to build ambari RPM from a brand new environment. I cloned
> >> https://
> >> github.com/u39kun/ambari-vagrant.git and followed all the steps in the
> >> Quick start Guide (
> >> https://cwiki.apache.org/confluence/display/AMBARI/Quick+Start+Guide)
> >>
> >> However I'm getting the error below while building. Have any of you
> faced
> >> that issue before? Thanks!!
> >>
> >> ambari-web-compile:
> >>      [exec] npm WARN package.json Ambari@1.7.0 No README data
> >>      [exec] npm http GET https://registry.npmjs.org/css-brunch
> >>
> >> ..skipping...
> >>
> >>  [exec] npm http 304
> https://registry.npmjs.org/ember-precompiler-brunch
> >>      [exec] npm ERR! Error: No compatible version found:
> mocha-phantomjs@
> >> '^3.1.6'
> >>      [exec] npm ERR! Valid install targets:
> >>      [exec] npm ERR!
> >>
> >>
> ["1.0.0","1.0.1","1.1.0","1.1.1","1.1.2","1.1.3","2.0.0","2.0.1","2.0.2","2.0.3","3.0.0","3.1.0","3.1.1","3.1.2","3.1.3","3.1.4","3.1.5","3.1.6","3.2.0","3.3.0","3.3.1","3.3.2","3.4.0","3.4.1","3.5.0"]
> >>      [exec] npm ERR!     at installTargetsError
> >> (/usr/share/node/lib/node_modules/npm/lib/cache.js:719:10)
> >>      [exec] npm ERR!     at
> >> /usr/share/node/lib/node_modules/npm/lib/cache.js:638:10
> >>      [exec] npm ERR!     at saved
> >>
> >>
> (/usr/share/node/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:142:7)
> >>      [exec] npm ERR!     at
> >>
> >>
> /usr/share/node/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:133:7
> >>      [exec] npm ERR!     at Object.oncomplete (fs.js:107:15)
> >>      [exec] npm ERR! If you need help, you may report this log at:
> >>      [exec] npm ERR!     <http://github.com/isaacs/npm/issues>
> >>      [exec] npm ERR! or email it to:
> >>      [exec] npm ERR!     <npm-@googlegroups.com>
> >>      [exec]
> >>      [exec] npm ERR! System Linux 2.6.32-358.el6.x86_64
> >>      [exec] npm ERR! command "/usr/share/node/bin/node"
> >> "/usr/share/node/bin/npm" "install"
> >>      [exec] npm ERR! cwd
> /home/vagrant/source-code/trunk/ambari/ambari-web
> >>      [exec] npm ERR! node -v v0.10.15
> >>      [exec] npm ERR! npm -v 1.3.5
> >>
> >> [exec] Result: 1
> >>      [exec]
> >>      [exec] /usr/share/node/lib/node_modules/brunch/lib/watch.js:433
> >>      [exec]             throw new Error("You probably need to execute
> `npm
> >> install` to ins
> >>      [exec]                   ^
> >>      [exec] Error: You probably need to execute `npm install` to install
> >> brunch plugins. Error: Cannot find module
> >>
> >>
> '/home/vagrant/source-code/trunk/ambari/ambari-web/node_modules/javascript-brunch'
> >>      [exec]   at
> >> /usr/share/node/lib/node_modules/brunch/lib/watch.js:433:19
> >>      [exec]   at Array.map (native)
> >>      [exec]   at loadDeps
> >> (/usr/share/node/lib/node_modules/brunch/lib/watch.js:418:10)
> >>      [exec]   at loadPackages
> >> (/usr/share/node/lib/node_modules/brunch/lib/watch.js:438:15)
> >>      [exec]   at
> >> /usr/share/node/lib/node_modules/brunch/lib/watch.js:458:19
> >>      [exec]   at
> >> /usr/share/node/lib/node_modules/brunch/lib/helpers.js:529:16
> >>      [exec]   at
> >> /usr/share/node/lib/node_modules/brunch/lib/helpers.js:485:14
> >>      [exec]   at
> >>
> >>
> /usr/share/node/lib/node_modules/brunch/node_modules/read-components/index.js:263:16
> >>      [exec]   at
> >>
> >>
> /usr/share/node/lib/node_modules/brunch/node_modules/read-components/index.js:72:14
> >>      [exec]   at Object.cb [as oncomplete] (fs.js:168:19)
> >>
> >
> >
>
> --
> CONFIDENTIALITY NOTICE
> NOTICE: This message is intended for the use of the individual or entity to
> which it is addressed and may contain information that is confidential,
> privileged and exempt from disclosure under applicable law. If the reader
> of this message is not the intended recipient, you are hereby notified that
> any printing, copying, dissemination, distribution, disclosure or
> forwarding of this communication is strictly prohibited. If you have
> received this communication in error, please contact the sender immediately
> and delete it from your system. Thank You.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message