ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rodrigo Meneses <rmene...@pivotal.io>
Subject Unable to build RPM for ambari Server
Date Mon, 06 Oct 2014 20:40:53 GMT
Hello,

I tried to build ambari RPM from a brand new environment. I cloned https://
github.com/u39kun/ambari-vagrant.git and followed all the steps in the
Quick start Guide (
https://cwiki.apache.org/confluence/display/AMBARI/Quick+Start+Guide)

However I'm getting the error below while building. Have any of you faced
that issue before? Thanks!!

ambari-web-compile:
     [exec] npm WARN package.json Ambari@1.7.0 No README data
     [exec] npm http GET https://registry.npmjs.org/css-brunch

..skipping...

 [exec] npm http 304 https://registry.npmjs.org/ember-precompiler-brunch
     [exec] npm ERR! Error: No compatible version found: mocha-phantomjs@
'^3.1.6'
     [exec] npm ERR! Valid install targets:
     [exec] npm ERR!
["1.0.0","1.0.1","1.1.0","1.1.1","1.1.2","1.1.3","2.0.0","2.0.1","2.0.2","2.0.3","3.0.0","3.1.0","3.1.1","3.1.2","3.1.3","3.1.4","3.1.5","3.1.6","3.2.0","3.3.0","3.3.1","3.3.2","3.4.0","3.4.1","3.5.0"]
     [exec] npm ERR!     at installTargetsError
(/usr/share/node/lib/node_modules/npm/lib/cache.js:719:10)
     [exec] npm ERR!     at
/usr/share/node/lib/node_modules/npm/lib/cache.js:638:10
     [exec] npm ERR!     at saved
(/usr/share/node/lib/node_modules/npm/node_modules/npm-registry-client/lib/get.js:142:7)
     [exec] npm ERR!     at
/usr/share/node/lib/node_modules/npm/node_modules/graceful-fs/polyfills.js:133:7
     [exec] npm ERR!     at Object.oncomplete (fs.js:107:15)
     [exec] npm ERR! If you need help, you may report this log at:
     [exec] npm ERR!     <http://github.com/isaacs/npm/issues>
     [exec] npm ERR! or email it to:
     [exec] npm ERR!     <npm-@googlegroups.com>
     [exec]
     [exec] npm ERR! System Linux 2.6.32-358.el6.x86_64
     [exec] npm ERR! command "/usr/share/node/bin/node"
"/usr/share/node/bin/npm" "install"
     [exec] npm ERR! cwd /home/vagrant/source-code/trunk/ambari/ambari-web
     [exec] npm ERR! node -v v0.10.15
     [exec] npm ERR! npm -v 1.3.5

[exec] Result: 1
     [exec]
     [exec] /usr/share/node/lib/node_modules/brunch/lib/watch.js:433
     [exec]             throw new Error("You probably need to execute `npm
install` to ins
     [exec]                   ^
     [exec] Error: You probably need to execute `npm install` to install
brunch plugins. Error: Cannot find module
'/home/vagrant/source-code/trunk/ambari/ambari-web/node_modules/javascript-brunch'
     [exec]   at /usr/share/node/lib/node_modules/brunch/lib/watch.js:433:19
     [exec]   at Array.map (native)
     [exec]   at loadDeps
(/usr/share/node/lib/node_modules/brunch/lib/watch.js:418:10)
     [exec]   at loadPackages
(/usr/share/node/lib/node_modules/brunch/lib/watch.js:438:15)
     [exec]   at /usr/share/node/lib/node_modules/brunch/lib/watch.js:458:19
     [exec]   at
/usr/share/node/lib/node_modules/brunch/lib/helpers.js:529:16
     [exec]   at
/usr/share/node/lib/node_modules/brunch/lib/helpers.js:485:14
     [exec]   at
/usr/share/node/lib/node_modules/brunch/node_modules/read-components/index.js:263:16
     [exec]   at
/usr/share/node/lib/node_modules/brunch/node_modules/read-components/index.js:72:14
     [exec]   at Object.cb [as oncomplete] (fs.js:168:19)

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message