ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmitro Lisnichenko" <dlysniche...@hortonworks.com>
Subject Re: Review Request 27426: ambari-agent shows usage hint on ambari-agent status
Date Fri, 31 Oct 2014 14:45:57 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/27426/#review59340
-----------------------------------------------------------

Ship it!


Ship It!

- Dmitro Lisnichenko


On Oct. 31, 2014, 2:16 p.m., Andrew Onischuk wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/27426/
> -----------------------------------------------------------
> 
> (Updated Oct. 31, 2014, 2:16 p.m.)
> 
> 
> Review request for Ambari and Dmitro Lisnichenko.
> 
> 
> Bugs: AMBARI-8066
>     https://issues.apache.org/jira/browse/AMBARI-8066
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> When ambari-agent is stopped, `ambari-agent status` command shows a usage hint
> as well. Looks like a bug since usage hint is usually shown when command is
> given invalid arguments. When issuing `ambari-agent status` with started
> agent, usage hint is not shown.
> 
>     
>     
>     
>     [root@0ab rpms]# ambari-agent stop
>     Verifying Python version compatibility...
>     Using python  /usr/bin/python2.6
>     Found ambari-agent PID: 1847
>     Stopping ambari-agent
>     Removing PID file at /var/run/ambari-agent/ambari-agent.pid
>     ambari-agent successfully stopped
>     [root@0ab rpms]# ambari-agent status
>     ambari-agent currently not running
>     Usage: /usr/sbin/ambari-agent {start|stop|restart|status}
>     [root@0ab rpms]# ambari-agent start
>     Verifying Python version compatibility...
>     Using python  /usr/bin/python2.6
>     Checking for previously running Ambari Agent...
>     Starting ambari-agent
>     Verifying ambari-agent process status...
>     Ambari Agent successfully started
>     Agent PID at: /var/run/ambari-agent/ambari-agent.pid
>     Agent out at: /var/log/ambari-agent/ambari-agent.out
>     Agent log at: /var/log/ambari-agent/ambari-agent.log
>     [root@0ab rpms]# ambari-agent status
>     Found ambari-agent PID: 1905
>     ambari-agent running.
>     Agent PID at: /var/run/ambari-agent/ambari-agent.pid
>     Agent out at: /var/log/ambari-agent/ambari-agent.out
>     Agent log at: /var/log/ambari-agent/ambari-agent.log
>     [root@0ab rpms]# 
>     
> 
> 
> Diffs
> -----
> 
>   ambari-agent/conf/unix/ambari-agent e867155 
> 
> Diff: https://reviews.apache.org/r/27426/diff/
> 
> 
> Testing
> -------
> 
> mvn clean test
> 
> 
> Thanks,
> 
> Andrew Onischuk
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message