ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myroslav Papirkovskyy" <mpapyrkovs...@hortonworks.com>
Subject Re: Review Request 26651: stale_configs parameter works incorrectly for Flume
Date Tue, 14 Oct 2014 12:54:30 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/26651/#review56513
-----------------------------------------------------------

Ship it!


Ship It!

- Myroslav Papirkovskyy


On Жов. 13, 2014, 8:26 після полудня, Dmitro Lisnichenko wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/26651/
> -----------------------------------------------------------
> 
> (Updated Жов. 13, 2014, 8:26 після полудня)
> 
> 
> Review request for Ambari, Myroslav Papirkovskyy and Nate Cole.
> 
> 
> Bugs: AMBARI-7761
>     https://issues.apache.org/jira/browse/AMBARI-7761
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> STR:
> Deployed cluster with Flume but without Flume Agents
> Added Flume agent component on each host.
> Crated config groups for Flume: group1(assigned host c6401) and group2(assigned host
c6402). Note that host c6403 is in Flume Default group.
> Overrided flume.conf for group1 and group2 with custom values.
> Restarted all components for Flume (there are no restart indicators after restart).
> Setted flume.conf for Flume Default group with custom value. (Flume Default had only
c6403).
> Clicked 'Save'.
> Result: Appeared restart indicators for Flume agents on all hosts, including hosts, which
are memberships of group1 and group2 (but configs were changed only for Flume agent in Flume
Default group). 
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/java/org/apache/ambari/server/state/ConfigHelper.java 8b724b1

>   ambari-server/src/test/java/org/apache/ambari/server/api/util/StackExtensionHelperTest.java
84ba6aa 
>   ambari-server/src/test/java/org/apache/ambari/server/controller/AmbariManagementControllerTest.java
96ebac3 
>   ambari-server/src/test/java/org/apache/ambari/server/state/ConfigHelperTest.java 73004ba

>   ambari-server/src/test/resources/stacks/HDP/2.0.6/services/FLUME/configuration/flume-conf.xml
PRE-CREATION 
>   ambari-server/src/test/resources/stacks/HDP/2.0.6/services/FLUME/configuration/flume-env.xml
PRE-CREATION 
>   ambari-server/src/test/resources/stacks/HDP/2.0.6/services/FLUME/configuration/flume-log4j.xml
PRE-CREATION 
>   ambari-server/src/test/resources/stacks/HDP/2.0.6/services/FLUME/metainfo.xml PRE-CREATION

> 
> Diff: https://reviews.apache.org/r/26651/diff/
> 
> 
> Testing
> -------
> 
> Results :
> 
> Failed tests:   testUpdateRepoUrlController(org.apache.ambari.server.controller.AmbariManagementControllerTest)
> 
> Tests run: 2107, Failures: 1, Errors: 0, Skipped: 17
> 
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO] 
> [INFO] Ambari Views ...................................... SUCCESS [8.889s]
> [INFO] Ambari Server ..................................... FAILURE [18:05.422s]
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 18:15.006s
> [INFO] Finished at: Mon Oct 13 20:22:31 FET 2014
> [INFO] Final Memory: 23M/300M
> [INFO] ------------------------------------------------------------------------
> 
> Unit test failure seems to be irrelevant and is observed also on trunk
>  
> 
> 
> Thanks,
> 
> Dmitro Lisnichenko
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message