ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Fernandez (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-7419) Unable to upgrade 1.6.1 -> 1.7.0 with external postgres
Date Mon, 22 Sep 2014 19:40:34 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-7419?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alejandro Fernandez resolved AMBARI-7419.
-----------------------------------------
    Resolution: Fixed

Resolved by commit 58611d8f6174a43e0199d95747ab2bbb990b81a3

> Unable to upgrade 1.6.1 -> 1.7.0 with external postgres
> -------------------------------------------------------
>
>                 Key: AMBARI-7419
>                 URL: https://issues.apache.org/jira/browse/AMBARI-7419
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 1.7.0
>            Reporter: Alejandro Fernandez
>            Assignee: Alejandro Fernandez
>             Fix For: 1.7.0
>
>
> install 1.6.1 with external postgres.
> upgrade server, agent
> run ambari-server upgrade
> start ambari-server and this is the error:
> {code}
> [root@c6401 yum.repos.d]# ambari-server upgrade
> Using python  /usr/bin/python2.6
> Upgrading ambari-server
> Updating properties in ambari.properties ...
> Adjusting ambari-server permissions and ownership...
> Ambari Server 'upgrade' completed successfully.
> [root@c6401 yum.repos.d]# ambari-agent start
> Verifying Python version compatibility...
> Using python  /usr/bin/python2.6
> Checking for previously running Ambari Agent...
> Starting ambari-agent
> Verifying ambari-agent process status...
> Ambari Agent successfully started
> Agent PID at: /var/run/ambari-agent/ambari-agent.pid
> Agent out at: /var/log/ambari-agent/ambari-agent.out
> Agent log at: /var/log/ambari-agent/ambari-agent.log
> [root@c6401 yum.repos.d]# ambari-server start
> Using python  /usr/bin/python2.6
> Starting ambari-server
> Traceback (most recent call last):
>   File "/usr/sbin/ambari-server.py", line 4601, in <module>
>     main()
>   File "/usr/sbin/ambari-server.py", line 4396, in main
>     start(options)
>   File "/usr/sbin/ambari-server.py", line 2497, in start
>     DATABASE_FULL_NAMES[args.dbms],
> KeyError: ''
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message