ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Cole (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMBARI-7191) Alerts: rename old alerts endpoint for new alerts and provide summary info
Date Mon, 08 Sep 2014 14:05:29 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-7191?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nate Cole resolved AMBARI-7191.
-------------------------------
    Resolution: Fixed

commit 1f1059cff1ac749e5bdc8fd98febccb7ca346652

> Alerts: rename old alerts endpoint for new alerts and provide summary info
> --------------------------------------------------------------------------
>
>                 Key: AMBARI-7191
>                 URL: https://issues.apache.org/jira/browse/AMBARI-7191
>             Project: Ambari
>          Issue Type: Task
>          Components: alerts, ambari-server, ambari-web
>            Reporter: Nate Cole
>            Assignee: Nate Cole
>             Fix For: 2.0.0
>
>
> Currently alerts (from Nagios) are propagated to the UI in the form:
> {noformat}
> {
>   "href" : "http://localhost:8080/api/v1/clusters/c1/services/HDFS?fields=alerts",
>   "ServiceInfo" : {
>     "cluster_name" : "c1",
>     "service_name" : "HDFS"
>   },
>   "alerts" : {
>     "detail" : [ ... ]
>     "summary": {
>       "OK": x,
>       "WARNING": y,
>       "CRITICAL": z
>     }
> }
> {noformat}
> This should be renamed to make way for the {{alerts}} endpoint.  Summary data should
be placed into an alerts_summary element.
> THIS IS AN API BREAKING CHANGE.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message