ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Cole (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-7191) Alerts: rename old alerts endpoint for new alerts and provide summary info
Date Sun, 07 Sep 2014 20:41:28 GMT
Nate Cole created AMBARI-7191:
---------------------------------

             Summary: Alerts: rename old alerts endpoint for new alerts and provide summary
info
                 Key: AMBARI-7191
                 URL: https://issues.apache.org/jira/browse/AMBARI-7191
             Project: Ambari
          Issue Type: Task
          Components: alerts, ambari-server, ambari-web
            Reporter: Nate Cole
            Assignee: Nate Cole
             Fix For: 2.0.0


Currently alerts (from Nagios) are propagated to the UI in the form:
{noformat}
{
  "href" : "http://localhost:8080/api/v1/clusters/c1/services/HDFS?fields=alerts",
  "ServiceInfo" : {
    "cluster_name" : "c1",
    "service_name" : "HDFS"
  },
  "alerts" : {
    "detail" : [ ... ]
    "summary": {
      "OK": x,
      "WARNING": y,
      "CRITICAL": z
    }
}
{noformat}

This should be renamed to make way for the {{alerts}} endpoint.  Summary data should be placed
into an alerts_summary element.

THIS IS AN API BREAKING CHANGE.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message