ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anthony Penniston (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-6612) Add property button disappear after choosing config group
Date Tue, 30 Sep 2014 15:22:34 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-6612?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14153272#comment-14153272
] 

Anthony Penniston commented on AMBARI-6612:
-------------------------------------------

update:
we do not notice this behavior in version 1.8.0 (the config is editable as long as the current
config is selected while changing config groups);
however:
It seems the larger problem here is that, despite changing config groups, config versions
are still loaded and displayed for the default group. Moreover, making changes to the config
groups other than the default does not appear to then allow those changes to be saved (clicking
the save button does nothing, nor updates the config versions list)
i.e.
1. make some changes to the default config and save it
2. create a new config group
3. switch to the new config group
--> observe that config versions for the default group are still displayed (though grayed
out), as well, the current selected config is set to the one that was previously selected
from the default group (rather than the current config of the current selected group). this
can be seen while debugging the function 'loadSelectedVersionSuccess' where, even on selecting
a config group that contains just a single version, a call is made to this.set('selectedVersion',
selectedVersion) with the selectedVersion being set from the the default config group (instead
of the selected config group).

> Add property button disappear after choosing config group
> ---------------------------------------------------------
>
>                 Key: AMBARI-6612
>                 URL: https://issues.apache.org/jira/browse/AMBARI-6612
>             Project: Ambari
>          Issue Type: Bug
>          Components: site
>    Affects Versions: 1.6.0
>         Environment: RHEL6, Chrome 36.0.1985.125
>            Reporter: Yixiao
>            Assignee: Anthony Penniston
>              Labels: config, custom, web, webgui, xml
>   Original Estimate: 24h
>  Remaining Estimate: 24h
>
> When you have custom configuration groups, click the HDFS service's configs, it shows
you the default config group. Expand custom hdfs-site.xml, it shows you a option of "add property".
 
> Choose your custom config group, the "add property" button disappear forever. It won't
come back when you switch back to the default group.
> Reload the page to get the "add property" button back.
> This affects all the services with the Custom xxx-site.xml configs.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message