ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mingjiang Shi <m...@pivotal.io>
Subject Unabled to build ambari due to unable to find suitable version for angular
Date Thu, 18 Sep 2014 09:22:53 GMT
Hi There,
Ambari build failed when building ambari-admin, with the following error:

[INFO] --- exec-maven-plugin:1.3.2:exec (Bower install) @ ambari-admin ---
> bower angular-animate#~1.2.23   cached git://
> github.com/angular/bower-angular-animate.git#1.2.25
> bower angular-animate#~1.2.23 validate 1.2.25 against git://
> github.com/angular/bower-angular-animate.git#~1.2.23
> bower angular#1.2.25            cached git://
> github.com/angular/bower-angular.git#1.2.25
> bower angular#1.2.25          validate 1.2.25 against git://
> github.com/angular/bower-angular.git#1.2.25
> bower angular#*                 cached git://
> github.com/angular/bower-angular.git#1.2.25
> bower angular#*               validate 1.2.25 against git://
> github.com/angular/bower-angular.git#*
> bower angular#>=1               cached git://
> github.com/angular/bower-angular.git#1.2.25
> bower angular#>=1             validate 1.2.25 against git://
> github.com/angular/bower-angular.git#>=1
> bower angular#1.2.23            cached git://
> github.com/angular/bower-angular.git#1.2.23
> bower angular#1.2.23          validate 1.2.23 against git://
> github.com/angular/bower-angular.git#1.2.23
> bower                        ECONFLICT Unable to find suitable version for
> angular
>

Manually ran the command and it gave the following options:
    1) angular#~1.2.18 which resolved to 1.2.23 and is required by
adminconsole
    2) angular#1.2.23 which resolved to 1.2.23 and is required by
angular-route#1.2.23
    3) angular#1.2.25 which resolved to 1.2.25 and is required by
angular-animate#1.2.25
    4) angular#>=1 which resolved to 1.2.25 and is required by
angular-bootstrap#0.11.0
    5) angular#* which resolved to 1.2.25 and is required by
restangular#1.4.0

So I added the following code
  "resolutions": {
    "angular": "1.2.25"
  }
to file /ambari/ambari-admin/src/main/resources/ui/admin-web/bower.json,
and the build is working now.

Anyone know if this is caused by some recent changes as it was working?
Thanks!

-- 
Cheers
-MJ

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message