ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk" <aonis...@hortonworks.com>
Subject Re: Review Request 25221: GET /api/v1/clusters/cluster/configurations endpoint is throwing 500
Date Mon, 01 Sep 2014 10:02:49 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/25221/#review51983
-----------------------------------------------------------

Ship it!


Ship It!

- Andrew Onischuk


On Sept. 1, 2014, 10:01 a.m., Dmytro Sen wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/25221/
> -----------------------------------------------------------
> 
> (Updated Sept. 1, 2014, 10:01 a.m.)
> 
> 
> Review request for Ambari, Andrew Onischuk and Mahadev Konar.
> 
> 
> Bugs: AMBARI-7096
>     https://issues.apache.org/jira/browse/AMBARI-7096
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> Post-install, I created a new HDFS config group.
> I added an override and hit Save.
> Now Config page no loader loads because the server throws 500 (NPE) on GET /api/v1/clusters/cluster/configurations.
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/java/org/apache/ambari/server/state/ConfigImpl.java 2f844d5

>   ambari-server/src/main/java/org/apache/ambari/server/state/configgroup/ConfigGroupImpl.java
96bedf8 
>   ambari-server/src/test/java/org/apache/ambari/server/state/cluster/ClusterTest.java
b2bb602 
> 
> Diff: https://reviews.apache.org/r/25221/diff/
> 
> 
> Testing
> -------
> 
> Tests run: 1958, Failures: 0, Errors: 0, Skipped: 15
> 
> 
> Thanks,
> 
> Dmytro Sen
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message