ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-6845) Ambari should work with python 2.7 installed
Date Wed, 13 Aug 2014 14:50:11 GMT
Andrew Onischuk created AMBARI-6845:
---------------------------------------

             Summary: Ambari should work with python 2.7 installed
                 Key: AMBARI-6845
                 URL: https://issues.apache.org/jira/browse/AMBARI-6845
             Project: Ambari
          Issue Type: Bug
            Reporter: Andrew Onischuk
            Assignee: Andrew Onischuk
             Fix For: 1.8.0


RHEL7 included python 2.7 by default and if you attempt to install Ambari, it
fails due to a dependency.

    
    
    
    Error: Package: ambari-server-1.7.0-88.noarch (AMBARI.1.7.0-trunk-1.x)
               Requires: python(abi) = 2.6
               Installed: python-2.7.5-16.el7.x86_64 (@anaconda/7.0)
                   python(abi) = 2.7
                   python(abi) = 2.7
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    

Check yum deplist ambari-server, looks like we say >= 2.6 for python but there
is another python package that is = 2.6...

    
    
    
    package: ambari-server.noarch 1.7.0-88
      dependency: /bin/sh
       provider: bash.x86_64 4.2.45-5.el7
      dependency: openssl
       provider: openssl.x86_64 1:1.0.1e-34.el7_0.3
      dependency: postgresql-server >= 8.1
       provider: postgresql-server.x86_64 9.2.7-1.el7
      dependency: python >= 2.6
       provider: python.x86_64 2.7.5-16.el7
      dependency: python(abi) = 2.6
       Unsatisfied dependency
    





--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message