ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From subin <subin.apa...@gmail.com>
Subject Ambari-admin failing for 'imagemin-gifsicle'
Date Wed, 20 Aug 2014 12:55:48 GMT
Hi

I am unable to compile ambari-admin on centos6.5
[INFO] Ambari Main ....................................... SUCCESS
[4:19.054s]
[INFO] Apache Ambari Project POM ......................... SUCCESS [0.964s]
[INFO] Ambari Web ........................................ SUCCESS
[1:24.482s]
[INFO] Ambari Views ...................................... SUCCESS [27.578s]
[INFO] Ambari Admin View ................................. FAILURE [35.377s]

I get the below error.

[12:34:59] Error: Cannot find module 'imagemin-gifsicle'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous>
(/vagrant/ambari/ambari-admin/src/main/resources/ui/admin-web/node_modules/gulp-imagemin/node_modules/imagemin/index.js:170:27)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)



Any ideas on how to overcome this ?
-- 
~Subin

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message