ambari-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk" <aonis...@hortonworks.com>
Subject Re: Review Request 24890: Cluster deployment fails if api.authenticate=false
Date Wed, 20 Aug 2014 14:13:20 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/24890/#review51099
-----------------------------------------------------------

Ship it!


Ship It!

- Andrew Onischuk


On Aug. 20, 2014, 2:11 p.m., Dmytro Sen wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/24890/
> -----------------------------------------------------------
> 
> (Updated Aug. 20, 2014, 2:11 p.m.)
> 
> 
> Review request for Ambari and Andrew Onischuk.
> 
> 
> Bugs: AMBARI-6940
>     https://issues.apache.org/jira/browse/AMBARI-6940
> 
> 
> Repository: ambari
> 
> 
> Description
> -------
> 
> If API authentication is turned off in ambari.properties then cluster deployment fails
> Ambari-server returns 403 Forbidden for POST request to http://c6401:8080/api/v1/clusters/c1
after clicking Deploy button
> {
>   "status": 403,
>   "message": "Forbidden"
> }
> 
> 
> Diffs
> -----
> 
>   ambari-server/src/main/java/org/apache/ambari/server/state/cluster/ClustersImpl.java
c27797e 
> 
> Diff: https://reviews.apache.org/r/24890/diff/
> 
> 
> Testing
> -------
> 
> Results :
> 
> Tests run: 1943, Failures: 0, Errors: 0, Skipped: 15
> 
> 
> Manually deployed cluster
> 
> 
> Thanks,
> 
> Dmytro Sen
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message